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Preface

Purpose

The purpose of this guide is to help the Teradata Manager user become familiar 
with some of the general capabilities of this versatile product. You can go 
straight through the guide, chapter by chapter, or you can skip around and only 
use the sections applicable to your work situation. The primary goal is to 
introduce those working with Teradata Manager to this exciting set of tools.

Supported Releases

This book supports the following releases:

• Teradata V2R4.1.1
• Teradata Tools and Utilities 06.01.01
• Teradata Manager 05.00.01

Changes to Teradata Manager

The following features and enhancements are new for release 5.0 of Teradata 
Manager. For details on the contents of this and subsequent minor releases, 
please see the Teradata Tools and Utilities Release Summary.

Application Feature / Enhancement

All Applications Teradata Manager supports Teradata RDBMS V2R4.1.1

Alerts System The Alert Policy can be set up to monitor three additional 
types of data:

• CPU Skew % - A measure of how well a session is using 
the system parallelism.

• Delta CPU Time - The CPU time accrued by a session 
during the latest monitoring interval. This can be used to 
identify runaway queries.

• Response Time - The time it takes for the alerts system to 
fetch performance data from the RDBMS. This can be used 
to identify system hang conditions.

The Alert Viewer displays new session skew data when 
monitoring a V2R4.1 system.

Teradata Manager can alert on RDBMS event messages from 
an SMP Teradata RDBMS running on Windows NT or 
Windows 2000.

New for 5.0.1: The Alerts policy allows specification of a non-
TPA node count for the Node Down event.
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General Usability Most Teradata Manager applications save their window size 
and position across invocations, so that the next time you start 
an application, it automatically sizes and positions itself 
according to its previous position and dimensions.

Monitor Object New MonitorVersion read-only property allows you to 
programmatically determine the version of PMPC on the 
Teradata RDBMS.

New GetSQL function allows you to retrieve a session's 
current SQL, execution step, and explain text from Teradata 
V2R4.1 systems.

The Session object has been extended to provide information 
on session skewing.

C++ users can access new monitor object functionality by 
incorporating the new TDMon.h and TDMon_i.c files into 
their projects.

PM Data Collector New logging options allow you to save detailed performance 
data for nodes, vprocs, and sessions in tab-delimited files for 
later analysis.

There is support for client-initiated action requests, including: 
Set Monitor Rates (RSS Monitoring), Set Session Rates, Abort 
Session, and Modify Session Account.

RDBMS Setup A new interface allows you to specify perm space and spool 
space for both the dbcmngr database and the Teradata 
Manager user in megabytes or in gigabytes.

An Abort button has been added to allow you to stop an in-
progress setup.

Remote Console There is added support for the following Teradata console 
utilities: 

• DBS Control
• Lock Display (available in V2R4)
• Priority Scheduler (available via remote console in 

V2R4.1)
• Vproc Manager.

Resource History Enhanced reports in support of Teradata V2R4.1 coexistence 
(mixed platform) systems.

Application Feature / Enhancement
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Session Information The Session Details dialog contains fields for:

• CPU Skew % - The degree to which CPU activity was 
skewed for this session.

• Disk Skew % - The degree to which disk activity was 
skewed for this session.

Note:  The CPU Skew and Disk Skew fields only show data 
when monitoring a V2R4.1 Teradata system.

The following dialog boxes have been added:

• Current Query - Accessed by pressing the SQL button on 
the Session Details dialog, this shows the SQL statements 
being executed by the current session. It also shows an 
Explain of the query and which step is currently 
executing.

• Session Skew - Accessed by pressing the Skew button on 
the Session Details dialog, Shows detailed CPU and disk 
usage information for the current session.

Note:   The Query and Skew dialogs are only available when 
monitoring V2R4.1 or later.

The Set Monitor Rates, Abort Session and Modify Session 
Account commands can be executed in client-mode. 
(Previously, these commands required you to logon directly to 
Teradata.)

The Local Filters support up to 100 User Names and 20 Host 
IDs.

There is an immediate update selection on the Options menu.

Reports are saved with more useful naming schemes.

SNMP agent and 
MIB

The SNMP agent and MIB support new session data available 
from Teradata V2R4.1.

Space Usage Hierarchy report: a % Used column has been added.

Space by Vproc report: a Skew column has been added.

Space by Vproc for Table report: the Deviation % column is 
signed -- if current perm on a vproc is less than the average, 
then deviation is displayed as a negative number.

Space by Vproc for Table report: Number of Cylinders and 
Cylinder Utilization columns have been added.

SQLDC The SQL Data Collector can pick up RDBMS event messages 
from an SMP Teradata RDBMS running on Windows NT or 
Windows 2000. These messages can then be acted on by the 
Alerts system.

Statistics Collection Spreadsheet rows containing LONER statistics are 
highlighted.

Application Feature / Enhancement
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System 
Maintenance

New reports based on the Teradata Access Log allow you to 
see activity on databases, database objects, grants, denials, etc. 
System Maintenance includes 6 predefined access log reports, 
and allows you to build customized reports with filtering on 
access times and on table names.

The Reset AMP Usage dialog has been redesigned.

Teradata 
Performance 
Monitor 
(previously PMON)

The Session Details dialog contains fields for:

• CPU Skew % - The degree to which CPU activity was 
skewed for this session.

• Disk Skew % - The degree to which disk activity was 
skewed for this session.

Note:  The CPU Skew and Disk Skew fields only show data 
when monitoring a V2R4.1 Teradata system.

The following dialog boxes have been added:

• Current Query - Accessed by pressing the SQL button on 
the Session Details dialog, this shows the SQL statements 
being executed by the current session. It also shows an 
Explain of the query and which step is currently 
executing.

• Session Skew - Accessed by pressing the Skew button on 
the Session Details dialog, Shows detailed CPU and disk 
usage information for the current session.

Note:  The Query and Skew dialogs are only available when 
monitoring V2R4.1 or later.

The Set Monitor Rates, Abort Session and Modify Session 
Account commands can be executed in client-mode. 
(Previously, these commands required you to logon directly to 
Teradata.)

There is a new sort option for the Sessions window: CPU 
Skew.

There is a new listbox in the Filter section of the Session 
window that allows you to display only those sessions that 
are skewed towards a selected 'hot' AMP.

Teradata Performance Monitor can be executed in client-mode 
without running (without even installing) the Teradata 
Manager Executive. No Teradata Manager profile is needed.

Application Feature / Enhancement
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Audience

This book is intended for system users, programmers, application 
programmers, and other technical personnel who will be using Teradata 
Manager.

Visual Explain You can use Query Tags instead of Query IDs.

The database that the Explain Plan is stored in can be 
specified.

There is a new View Pad for navigating large explains.

The user can enter a query to be explained from within Visual 
Explain.

 QCDs can be created and maintained using Control Center.

The ability to find a string in the Explain or Query text.

Comparison between specified individual steps of different 
queries.

A Bulk Compare option to compare multiple queries in a 
batch mode.

There is additional information provided for the explain 
steps.

A large number of execution plans can be compared across 
QCDs and RDBMSs using Bulk Compare

The explain text of two execution plans can be compared 
using Explain Text Differences.

You can display captured vs. current statistics, indexes, and 
DDL schema details of the tables involved in the execution 
plan.

WinDDI There is a Tools menu command to configure Teradata Access 
Logging.

A popup list describes the account string expansion codes 
when creating a user. You can click in the list to insert a code 
at the current position in the account string.

Hash Indexes are supported.

There is a References report for Tables and Views. 

There are many improvements to the interface and to reports.

New for 5.0.1: Tree Load Filter options allow you to restrict 
the list of DBs/Users that will initially be loaded, in order to 
provide a much faster load time.

Wireless Device Receive Teradata performance data on your Palm VII.

Application Feature / Enhancement
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Prerequisites

You should be familiar with basic computer technology, the Teradata RDBMS, 
and the Microsoft Windows 2000, Windows NT, or Windows 95/98 operating 
system. You should have access to an installed version of Teradata Manager.

Related Documents

Teradata Tool and Utilities Support Publications

The general publications that support Teradata Tools and Utilities are listed 
below. The most recent versions of the publications are maintained on the NCR 
Information Products Publishing Web site. The online versions of these books 
will be updated as necessary to reflect any changes introduced between 
product releases

Note:   In the book numbers referenced below, the first eight characters are a 
unique Product ID for the book, and can be used to navigate to the book online. 
The mmyx represents the publication date, where mm is the month, y is the last 
digit of the year, and x is an internal code.

Product Related Publications

The additional publications that support Teradata Manager are listed below.

Document Number Title

B035-2029-mmyx Teradata Tools and Utilities Release Definition

B035-2427-mmyx Teradata Tools and Utilities Release Summary

B035-2407-mmyx Teradata Tools and Utilities Installation Guide for Windows™

B035-2415-mmyx Teradata Tools and Utilities Installation Guide for MVS™

B035-2420-mmyx Teradata Tools and Utilities Installation Guide for NCR UNIX® MP-
RAS

B035-2422-mmyx Teradata Tools and Utilities Installation Guide for VM™

B035-2437-mmyx Teradata Tools and Utilities Installation Guide for AIX™

B035-2438-mmyx Teradata Tools and Utilities Installation Guide for HP-UX®

B035-2439-mmyx Teradata Tools and Utilities Installation Guide for Solaris™

B035-2440-mmyx Teradata Tools and Utilities Installation Guide for OS/390 USS™

B035-1096-mmyx Teradata RDBMS Messages Reference

Document Number Title

B035-2402-mmyx Teradata Manager Installation Guide
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Technical Information on the Web
Technical Information on the Web

For technical support, additional information, or the latest versions of Teradata 
publications, you may access online information through the following NCR 
Web sites:

Link Description

http://www.info.ncr.com/ A direct link to NCR Information Products 
Publishing library where you can view, download, or 
order technical documentation and CD-ROMs.

 http://www.ncr.com/ The NCR home page provides links to numerous 
sources of information about Teradata. Among the 
links provided are sites that deal with the following 
subjects:

• Technical support
• Customer education courses
• Case studies of customer experiences with 

Teradata
• Third party industry analyses of Teradata data 

warehousing products
• White papers
• Online periodicals
Teradata Manager Getting Started Guide vii
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List of Acronyms
List of Acronyms

The following acronyms, listed in alphabetical order, are used in this book:

Acronym Definition

ASCII American National Standard Code for Information Interchange

BTEQ Basic Teradata Query facility

CLI Call-Level Interface

CLI2 Call-Level Interface Version2, also called CLI for Windows

CPU Central Processing Unit

DBA Database Administrator

DLL Dynamic Link Library

E-CLI Extended Call-Level Interface

ISO International Standards Organization

MIB Management Information Base

MPP Massively Parallel Processing

ODBC Open Database Connectivity

PPP Point-to-Point Protocol

PM & PC Performance Monitor and Production Controls

QCD Query Capture Database

QCF Query Capture Facility

RDBMS Relational Database Management System

RTF Rich Text File

SMP Symmetric Multi-Processing

SNMP Simple Network Management Protocol

SSO Single Sign On

SQL Structured Query Language

TCP/IP Transmission Control Protocol/Internet Protocol

TDPid Teradata Director Program ID, assigned by the system administrator

TTU Teradata Tools and Utilities

WinDDI Windows Data Dictionary Interface
Teradata Manager Getting Started Guideviii
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Chapter 1: 

The Basics

This chapter describes the Executive, which establishes the working 
environment for running Teradata Manager applications. This chapter covers 
the following.

• “Introducing the Executive” describes the uses of this application in the 
Teradata Manager suite.

• “The Executive Menu Bar” introduces you to the program’s many menu 
options.
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Introducing the Executive
Introducing the Executive

The Profile Builder and the Executive establish the working environment for 
running Teradata Manager applications. The Profile Builder allows you to 
tailor your Teradata Manager default options, while the Executive provides the 
interface for working with the Teradata Manager applications themselves. 

Tailor Your Teradata Manager Environment With Profile Builder

Using the Profile Builder application, you can customize many aspects of the 
working environment, including the name of the RDBMS, the applications that 
are accessible through the Executive pull-down menus, program autostart 
information, and the names and locations of various log files. You can create as 
many profiles as necessary to accommodate the various combinations of 
activities performed at your site. 

Launch Teradata Manager Applications With the Executive

Typically, you will start Teradata Manager by clicking on it’s shortcut icon, 
which will in turn start the Executive application. The Executive provides you 
with facilities for starting other Teradata Manager applications, either by using 
pull-down menus, or by entering an executable name into the Run dialog.

Enable and Disable Autostart Applications

Teradata Manager also provides the option of having applications start 
automatically when the Executive is launched, or at selected times during the 
day or week. The Executive provides flexible autostart facilities for launching 
any program you can normally access through Windows.
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The Executive Menu Bar
The Executive Menu Bar

The Executive window looks like this:

The menu bar runs along the top of the Executive window and contains the 
names of the Executive pull-down menus. 

The Profile Menu

The Profile menu is the first one on the menu bar (going from left to right). The 
Profile menu provides options for setting up the application menus and 
changing other profile options, running applications, and exiting Teradata 
Manager.

Select This Menu Item... To...

Menu Setup Add, change, delete, or rearrange the dynamic menu items 
on the Executive menu bar.

Menustart Setup Add, change, delete, or rearrange the menustart applications 
listed under a dynamic menu item on the Executive menu 
bar.

Autostart Setup Add, change, reschedule, or delete autostart applications.
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The Executive Menu Bar
The Options Menu

The Options menu is the next one over on the menu bar. The Options menu 
allows you to set overall Teradata Manager preferences, font styles and sizes, 
select profiles, and globally enable/disable the autostart function.

The View Menu

The View Menu allows you to toggle the toolbar and status bar on and off.

Run Run a program through a command-line entry.

Save Save the changes you have made to a profile.

Log File Add a note to the log file or start a new log file.

Default Logon Info Change the logon information.

Exit Exit Teradata Manager.

Select This Menu Item... To...

Preferences Tailor the working environment of the Teradata Manager 
Executive.

Font Change the font, style and size of the characters displayed in 
the selected (foreground) profile window.

Profiles Select one of the following:

• Modify Active Profiles to change the active profiles in 
your Teradata Manager session

• Select Foreground to select a specific active profile as the 
foreground profile

• Toggle Foreground to toggle the active profiles to the 
foreground position, in sequence.

Global Autostart 
Enable

Enable the autostart capability for all profiles.

Global Autostart 
Disable

Disable the autostart capability for all profiles.

Select This Menu Item... To...

Toolbar Toggle the toolbar so that it is visible or not.

Status Bar Toggle the status bar so that it is visible or not.

Select This Menu Item... To...
Teradata Manager Getting Started Guide1 – 4
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The Executive Menu Bar
The Tools Menu

This menu gives you access to the Tools set of Teradata Manager applications.

The Performance Menu

This menu gives you access to the Performance set of Teradata Manager 
applications.

Select This Menu Item... To...

Alert Control 
Module

Initiate the alerting process for Teradata Manager.

Alert Policy Editor Define the actions that should take place when specific 
events occur on one or more Teradata machines.

Alert Viewer Provides a single view point on the overall system 
performance for one, or multiple, Teradata RDBMS systems. 

BTEQWIN Load and extract data from the Teradata RDBMS using a 
version of BTEQ with a windows interface.

DMTEQ Load and extract data from the Teradata RDBMS.

RDBMS Setup Set up the RDBMS to run Teradata Manager and create or 
modify a Teradata Manager user.

Time Synchronizer Synchronize your PC clock with the Teradata RDBMS.

Visual Explain Generate graphic representations of the execution plans 
chosen by the Teradata RDBMS Optimizer to access data. You 
can compare execution plans, and even make comparisons 
across databases.

WinDDI Perform database administration tasks on the Teradata 
RDBMS computer.

Select This Menu Item... To...

DUC (Using PMPC) Display near real-time Teradata RDBMS resource usage data 
(using Performance Monitor data) on your Teradata Manager 
PC in chart format.

Performance Data 
Analyzer

Summarize Teradata RDBMS resource usage data in chart 
format using data from the resource usage tables on the 
Teradata RDBMS.

PM Data Collector Collect Teradata RDBMS performance data, while minimizing 
the impact of obtaining such data from the RDBMS.
Teradata Manager Getting Started Guide 1 – 5
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The Executive Menu Bar
The Production Control Menu

This menu gives you access to the Production Control set of Teradata Manager 
applications

Teradata 
Performance 
Monitor

Analyze the performance of a Teradata machine and to 
perform related control functions on that machine.

Resusage Data 
Collector

Collect data from tables on the Teradata RDBMS and write the 
data to files and memory objects on your Teradata Manager 
PC. 

Select This Menu Item... To...

Configuration Check Collect configuration information related to a Teradata 
RDBMS.

Error Log Analyzer View the error log system tables on the Teradata RDBMS. 

Locking Logger Determine whether system performance has been degraded 
by an inappropriate mix of SQL statements using a table of 
information extracted from the transaction logs.

LogOnOff Usage Present daily, weekly, and monthly logon statistics based on 
information in the DBC LOGONOFF view on the Teradata 
RDBMS.

Remote Console Run many of the Teradata RDBMS console utilities from 
your Teradata Manager PC.

Resource History View or print reports showing the maximum and average 
usage of Logical Disk Vprocs (LDVs), AMP Vprocs, and PE 
Vprocs on the Teradata RDBMS. Run NODE usage macros 
on the associated Teradata RDBMS. Display data utilization  
for Teradata coexist platforms.

Session Information Monitor, identify and abort sessions on the Teradata 
RDBMS.

Space Usage Monitor disk space utilization and move permanent space 
from one database to another.

Statistics Collection Create, drop and update statistics for the Teradata RDBMS.

System Maintenance Maintain and monitor system tables on the Teradata 
RDBMS. Provides Access Log Audit reporting.

Select This Menu Item... To...
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The Executive Menu Bar
The Window Menu

The Window Menu allows you to open new application windows, arrange the 
windows on your screen, and select which window to make active from a list of 
open windows.

The Help Menu

The Help Menu allows you to bring up the application help, get information on 
using the help system, and get version information about the open application.

Ready to Go

Now that you have become familiar with the Executive interface, you are ready 
to move on to the next chapter where you will create a profile, then begin using 
Teradata Manager.

Select This Menu Item... To...

New Window Open a new log window.

Cascade Arrange the open windows in a cascading pattern.

Tile Arrange the open windows in a tile pattern.

Arrange Icons Clean up the icons on your screen.

Profile Name Select a window and make it active.

Select This Menu Item... To...

Help Topics Open the application help file.

Using Help Get information on using the help system.

About Teradata 
Manager Executive

Get version information about the application.
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Chapter 2: 

Getting Teradata Manager Running

The purpose of this chapter is to help you get Teradata Manager running. You 
will learn how to:

• Create the Teradata Manager Databases, Tables, and Macros 
• Add Teradata Manager Users 
• Create a Default Profile for Teradata Manager 
• Start The Executive 
• Synchronize Teradata Manager (PC) Time With the RDBMS 
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Create the Teradata Manager Databases, 
Tables, and Macros

Once Teradata Manager has been installed, the Teradata RDBMS needs to be set 
up with the databases, tables, and macros necessary to run Teradata Manager. 
The RDBMS Setup application will assist you in this task.

How does it work?

RDBMS Setup uses your parameters to generate SQL statements for creating 
and modifying databases/tables/macros on the specified RDBMS. Each SQL 
statement and whether it was submitted successfully or unsuccessfully is 
logged in the main window of the application.
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Procedure

To set up the Databases, Tables, and Macros required by Teradata Manager, 
follow this procedure:

Step Action

1 Start RDBMS Setup by selecting Start > Programs > Teradata Manager 5.0.1 > 
RDBMS Setup.

2 From the RDBMS Setup menu bar, select File > RDBMS Setup. This displays 
the RDBMS Setup dialog box. 
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3 Fill in the fields as follows:

• RDBMS Name is the TDPid of the Teradata RDBMS.
• Super User is the name of the primary administrator for the database. This 

defaults to DBC.
• Super User Password is the string the primary administrator enters to 

access the database.
• Console Password is the console user’s password. If the console user 

already exists, then RDBMS Setup will logon to the RDBMS as ‘console’, 
using the password that you supply. If the console user does not exist, the 
‘console’ user is created and assigned the supplied password.

• Set up RDBMS for Teradata Manager must be checked.
• Perm Space is the amount of permanent space allocated to the new 

RDBMS.
• Spool Space is the amount of spool space allocated to the new RDBMS. If 

you want the new RDBMS to inherit the same amount of space as its 
parent, check the Same as Parent option.

• Create a Teradata Manager User allows you to create a user. For the sake of 
simplicity, un-check this item (this topic is covered in the next procedure).

4 Click OK to run RDBMS Setup with your parameters. A log of the program 
results are displayed in the main window of the application.

Step Action
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Add Teradata Manager Users

Once the Teradata Manager databases, tables, and macros have been set up, 
you can add users, giving them the various permissions necessary to run the 
Teradata Manager applications. The RDBMS Setup application will assist you 
in this task.

Procedure

To add a user with permission to run Teradata Manager applications, follow 
this procedure:

Step Action

1 Start RDBMS Setup by selecting Start > Programs > Teradata Manager 5.0.1 > 
RDBMS Setup.

2 From the RDBMS Setup menu bar, select File > RDBMS Setup. This displays 
the RDBMS Setup dialog box.

3 Select the options as follows:

• Deselect the Set up RDBMS for Teradata Manager option.
• Select the Create a Teradata Manager User option.
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4 Fill in the fields as follows:

• RDBMS Name is the TDPid of the Teradata RDBMS.
• Super User is the name of the primary administrator for the database. This 

defaults to DBC.
• Super User Password is the string the primary administrator enters to 

access the database.
• Console Password is the console user’s password. If the console user 

already exists, then RDBMS Setup will logon to the RDBMS as ‘console’, 
using the password that you supply. If the console user does not exist, the 
‘console’ user is created and assigned supplied password.

• Set up RDBMS for Teradata Manager must be unchecked.
• User Name is the login name you wish to give the Teradata Manager user.
• User Account String is the RDBMS related account string for the new user.
• User Password is the string the user enters to access Teradata Manager.
• Confirm Password is the same as the User Password.
• Perm Space is the amount of permanent space allocated to the new user. 

Enter the desred value.
• Spool Space is the amount of spool space allocated to the new user. Enter 

the desired value. If you want the new user to inherit the same amount of 
space as its parent, check the Same as Parent option.

• The user will be able to run all applications listed in the Give user privileges 
to run box. To move applications from one box to another, highlight them, 
then click the arrow pointing towards the box you want to move them to.

5 Click OK to run RDBMS Setup with your parameters. A log of the program 
results are displayed in the main window of the application.

Step Action
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Create a Default Profile for Teradata 
Manager

Before running Teradata Manager, you need to create a profile. The function of 
the profile is to configure Teradata Manager for a specific type of monitoring 
activity. This ability to create custom configurations provides an effective way 
for you to use Teradata Manager in various operational situations. For example:

• If you need to access more than one Teradata RDBMS, you can define 
different profiles for each database.

• If you need more than one person or group of people to use Teradata 
Manager, you can define different profiles for each person or group.

• If your operational needs change on a regular basis, or from one shift to 
another, you can define different profiles for each shift.

Procedure

To create a default profile that will allow you to start Teradata Manager 
Executive and access the desired applications, follow this procedure: 

Step Action

1 Start Profile Builder by selecting Start > Programs > Teradata Manager 5.0.1 > 
Profile Builder.

2 From the Profile Builder menu bar, select Profile > Default.

Profile Builder creates a new default profile, and adds the profile window as 
the currently selected (foreground) profile in the Profile Builder window.

Note: If you already have a profile named DEFAULT, Teradata Manager 
displays a message asking if you want to overwrite it.
Teradata Manager Getting Started Guide 2 – 7



Chapter 2: Getting Teradata Manager Running
Create a Default Profile for Teradata Manager
3 Select Profile > Default Logon Info from the menu bar. This displays the Change 
Default Logon Information dialog box. 

4 Fill in the fields as follows:

• RDBMS Name is the TDPid of the Teradata RDBMS.
• User Id is the default user identifier for the profile. If your site supports 

the SSO (Single Sign On) feature, you may leave this field blank.
• Account Id is optional account information.
• Teradata RDBMS Release provides a list box to select the release version of 

the software running on the Teradata RDBMS.
• Use the Ahead of or Behind option buttons and the Hours and Minutes fields 

to specify any system time differences between your Teradata Manager 
PC and the Teradata RDBMS. If there is no system time difference, enter 0 
in the Hours and Minutes fields.

5 Select Profile > Save from the menu bar before exiting Profile Builder to save 
the new default profile.

Step Action
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Start The Executive

Now that all the necessary pieces have been set up, you can start the Teradata 
Manager Executive.

Procedure

To start the Teradata Manager Executive, follow this procedure:

Step Action

1 Start the Executive by selecting Start > Programs > Teradata Manager 5.0.1 > 
Teradata Manager. This displays the Modify Active Profiles dialog box.

2 Move the profile DEFAULT from the Available Profiles box to the Active Profiles 
box by first highlighting the item, then clicking Add. This will cause the 
Executive to run the DEFAULT profile when it starts.
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Note:  If you plan to use single sign-on from Teradata Manager applications on 
Windows NT 4.0 or Windows 9x and your domain controller is a Windows 
2000 server, then make sure the domain is operating in mixed mode. For more 
information, see Microsoft documentation on domain modes.

3 Click OK. This displays the Logon Information dialog box.

4 The fields appear with the DEFAULT profile parameters. You may make any 
changes by filling in the fields as follows:

• RDBMS Name is the TDPid of the Teradata RDBMS.
• User Id is the default user identifier for the profile. If your site supports 

SSO (Single Sign On), you may leave this field blank.
• Password is the login password for the User Id. If your site supports SSO, 

you may leave this field blank.
• Account Id is optional account information.
• Teradata RDBMS Release provides a list box to select the release version of 

the software running on the Teradata RDBMS.
• Use the Ahead of or Behind option buttons and the Hours and Minutes 

fields to specify any system time differences between your Teradata 
Manager PC and the Teradata RDBMS. If there is no system time 
difference, enter 0 in the Hours and Minutes fields.

5 Click OK to complete the logon process.

Step Action
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Synchronize Teradata Manager (PC) Time 
With the RDBMS

When working with Teradata Manager, it is important that the local clock on 
your PC is synchronized with the clock on the Teradata RDBMS. The Time 
Synchronizer application takes care of this task.

Note:  You must have permission to change the PC time in order to run this 
application.

Procedure

To synchronize your PC time with the Teradata RDBMS time, follow this 
procedure:

Step Action

1 Start the Executive by selecting Start > Programs > Teradata Manager 5.0.1 > 
Teradata Manager, and log on to the Teradata RDBMS you will be working 
with. See “Start The Executive” on page 2-9 for instructions.

2 Select Tools > Time Synchronizer from the Executive menu bar. Time 
Synchronizer starts in a minimized mode, and after a few moments, displays 
one of the following dialogs.

If your PC time is within the allowable limit set up in Time Synchronizer, this 
dialog box is displayed:

If you see this dialog box, click No to close it. Time Synchronizer will 
terminate with no actions taken.
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3 If your PC time is not within the allowable limit set up in Time Synchronizer, 
this dialog box is displayed:

Click Yes to display the following dialog box.

4 The fields display the date and time as they are set on the two platforms, as 
well as the allowable time difference. Fill in the fields as follows:

• Select Synchronize PC with RDBMS Clock to automatically set your PC to 
the RDBMS date/time.

• Select User Defined Date/Time if you want to change the PC settings, but do 
not want them set exactly the same as the RDBMS date/time. When you 
make this selection, date and time input fields appear which you must 
then fill in.

• The settings in the PC Date/Time area allow you to set the acceptable limits 
(ahead and behind) the PC may be from the RDBMS clock before you are 
warned by Time Synchronizer.

5 Click OK. Time Synchronizer will terminate after setting the PC time and 
defined limits as you requested.

Step Action
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Starting Teradata Manager Applications

This chapter contains information on running the Teradata Manager 
applications. This chapter contains sections on:

• Setting Up Teradata Manager Applications 
• Starting Applications Manually (Menustart) 
• Starting Applications Automatically (Autostart) 
• Running Applications Under the Windows 2000/NT Command Shell 
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Setting Up Teradata Manager Applications

The menu items at the top of the Executive window are associated with the 
selected profile. For example, the Default profile has the Tools, Performance, 
and Production-Control menu items. (The Profile, Options, and Window menu 
items are common to all profiles.) Pulling down each of these menus displays 
applications that you can select to start

Application Names

Each Teradata Manager application is identified by its program executable file 
name and an application name. The application name is the name by which the 
executable is referenced in this guide, in profiles, and on menus. You can 
rename an application, for example, to more easily identify it with an 
operation. The maximum length of an application name is 30 characters. You 
specify the name of an application in the Application Name field on the 
Autostart or Menustart setup dialog of either the Executive or Profile Builder. A 
cross-reference of executable file names to application names is shown in Table 
3-1. 

Table 3-1    Application Names vs. File Names

Application Name Executable File Name

Alert Control Module ACM.EXE

Alert Policy Editor APE.EXE

Alert Viewer ALERT.EXE

Configuration Check CCHK.EXE

PM Data Collector TMDATCOL.EXE

SQL Data Collector SQLDC.EXE

DMTEQ DMTEQ.EXE

Dynamic Utilization Charting (using 
PM & PC)

PMDUC.EXE

Error Log Analyzer ELA.EXE

Locking Logger LOCK.EXE

Log Change LOGCHG.EXE

Log Delete LOGDEL.EXE

LogOnOffUsage LOGUSE.EXE

Performance Data Analyzer PDA.EXE

Teradata Performance Monitor PMONV2.EXE
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Executable File Names

The executable file name for a Teradata Manager application is the name of the 
program file for the application. Like the application name, the executable file 
name is requested when setting up an application to run under the Executive. 
You enter the executable file name in the Execution Path field on the Autostart 
or Menustart Setup dialog of either the Executive or Profile Builder. The full 
path is not required unless the application is user-supplied and is in a directory 
other than the one specified in the search path.

Names for applications that are renamed can be determined by the executable 
file name. A cross-reference of executable file names to application names is 
shown in Table 3-1.

Parameters

Parameters specify the options for running some applications. Parameters are 
normally required when setting up an application to run in batch mode.

You enter the parameters for an application in the Parameters field on the 
Autostart or Menustart Setup dialog of either the Executive or Profile Builder. 

Profile Builder PROBUILD.EXE

RDBMS Setup DBSSETUP.EXE

Remote Console RCONS.EXE

Resource History HISTORY.EXE

Resusage Data Collector RDC.EXE

Session Information SI.EXE

Space Usage SPACE.EXE

Statistics Collection STAT.EXE

System Maintenance SM.EXE

BTEQWIN BTEQWIN.EXE

Time Synchronizer TIMESYNC.EXE

TMCLIENT TMCLIENT.EXE

TMSERVER TMSERVER.EXE

Visual Explain VECOMP.EXE

WinDDI WINDDI.EXE

Wireless DISTSRV.EXE

Table 3-1   (Continued)  Application Names vs. File Names

Application Name Executable File Name
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Some applications allow using substitutable parameters. For example, you can 
use %PROFILE% to indicate the name of an associated profile, or %PROF8% to 
indicate the first eight characters of the associated profile name. For additional 
information about parameters refer to the Profile Builder online help.

Dependencies

Most dependencies for running applications are handled by Teradata Manager. 
Exceptions are described in the associated online help for the application. 
However, not all dependencies related to the configuration of data files are 
handled by Teradata Manager. We recommend that you do not move any 
Teradata Manager files unless you know it is safe to do so.
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Starting Applications Manually 
(Menustart)

Use the Menustart Setup dialog under either the Executive or Profile Builder to 
set up menustart applications. From the Menustart Setup dialog you can 
specify:

• The menu in which an application is to appear
• The name associated with the application
• The execution path for the application
• Any parameters for the application
• The initial size and position of the application window

Select the Menustart Setup command from the Profile menu of either the 
Executive or Profile Builder to open the Menustart Setup dialog. The procedure 
for completing the dialog is described in the Profile Builder online help. 

Figure 3-1 and Figure 3-2 show examples of completing the Menustart Setup 
dialog for the Alert Control Module and Session Information applications. 
These applications are both from the initial configuration of the Default profile.

Figure 3-1    Menustart Setup Dialog for Alert Control Module
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Figure 3-2    Menustart Setup Dialog for Session Information
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Starting Applications Automatically 
(Autostart)

Use the Autostart Setup dialog under either the Executive or Profile Builder to 
set up applications to start automatically. From the Autostart Setup dialog you 
can specify that an application will start:

• At program start-up
• At fixed intervals
• At a fixed time/date
• When an IF condition tests true

In addition to the required name and execution path, the Autostart Setup 
dialog allows you to enter any parameters for the application, as well as the 
initial size and position of the application window.

To open the dialog, select the Profile > Autostart Setup > Setup from the menu bar 
of the Executive, or Profile > Autostart Setup from the menu bar of Profile 
Builder. The procedure for completing the dialog is described in detail in the 
Profile Builder online help.

Figure 3-3 and Figure 3-4 show examples of completing the Autostart Setup 
dialog for the Log Change and Time Synchronizer applications. These 
applications are both from the initial configuration of the Default profile.

Figure 3-3    Autostart Setup Dialog for Log Change
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Figure 3-4    Autostart Setup Dialog for Time Synchronizer
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Running Applications Under the Windows 
2000/NT Command Shell

You can also set up Teradata Manager applications to run under the Windows 
2000/NT operating system command shell. Typically you would do this if you 
wanted to chain one application to one or more additional applications.

Note: This procedure will not work under Windows 95/98.

For example, it is a good idea to synchronize the time on the PC with the time 
on the database before running Resusage Data Collector. If you want Time 
Synchronizer to run before Resusage Data Collector, use a Windows editor to 
create a command file containing the following lines:

timesync
rdc resbase -f 600

Then, complete an Autostart or Menustart setup dialog using CMD.EXE as the 
execution path.

Use the name of your command file as the parameter. For example, if you 
named your command file RUNRDC.CMD, the menustart setup dialog may 
appear as shown in Figure 3-5 for a Windows 2000/NT system.

Figure 3-5    Command Shell Setup Example

Or you may want to run an application under the operating system command 
shell to redirect output to or from an application that does not provide alternate 
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input and output sources. DMTEQ, for example, does not allow input and 
output parameters, but you can set it to run under the command shell to 
redirect input and output.

To set up DMTEQ to use the script MyScript as input, and to redirect the output 
to MyScript.Out, use the following parameters with the appropriate execution 
path:

/c dmteq -P %PROFILE% < \MyScript > \MyScript.Out
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Creating Charts and Reports

One of the great benefits of Teradata Manager is the ability to produce reports 
on many types of database usage statistics. This chapter shows you how to get 
many types of resource usage reports, as well as reports showing system 
performance, logon statistics, and locking logger activity. This chapter shows 
you how to:

• Create Summary Resource Usage Charts 
• Create Historical Resource Usage Reports 
• Create Logon Statistics Reports 
• Create Performance Charts Using Teradata Performance Monitor 
• Create Performance Charts Using DUC 
• Create Locking Logger Reports 
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Create Summary Resource Usage Charts

Performance Data Analyzer (PDA) summarizes Teradata RDBMS resource 
usage data in chart format on your Teradata Manager PC. Trends depicted in 
the charts can help you detect abnormalities in resource usage, schedule 
production jobs, and balance Teradata RDBMS work loads.

You can chart a single column for several time periods, or several columns for a 
single time period. Resource usage data is collected from the resource usage 
tables on the associated Teradata RDBMS by Resusage Data Collector.

Procedure

To create the Summary Resource Usage Charts, do the following:

Step Action

1 PDA creates charts from the data collected by Resusage Data Collector 
(RDC). It is recommended in general that you let RDC run continuously to 
keep the data updated. If Resusage Data Collector has not been run, you can 
start it now by selecting Performance > Resusage Data Collector from the 
Executive menu bar. 

2 Start PDA by selecting Performance > Performance Data Analyzer from the 
Executive menu bar. 

3 Display the dialog to set the charting time periods by selecting Time > Define 
Time Period from the PDA menu bar.

4 Select the date or dates you want included from the Date Available list box in 
the Define Time Periods dialog.

5 Enter the time period(s) you want to include. Time periods may be entered in 
one of three formats:

• All hours on the selected dates (default).
• A specific period of time  on the selected dates.
• A predefined shift on the selected dates.

6 Select one or more processor types by checking one or more Data Type Boxes: 
AMP vproc, PE vproc, or Node.

7 Click Define. 

8 Repeat steps 4 - 7 until all the required time periods are defined.

9 Click Done to close the dialog.

10 Display the dialog to create charts by selecting Date > Chart Data from the 
PDA menu bar.
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11 Select a data type (AMP vproc, PE vproc, or Node) from the Data Type group 
box. 

Note:  If time periods for a processor type have not been defined, the option 
for that type is not available.

12 Choose either the Multiple Data Columns or the Multiple Time Periods chart 
type from the Chart Type group box. 

13 Select one or more data columns from the Data Columns list box. 

14 Select a time period from the Defined Time Periods list box. 

15 When you are finished defining the chart, generate the chart by clicking OK. 

Once PDA finishes building the chart, it displays it on the work space. 

Step Action
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Create Historical Resource Usage Reports

Resource History provides reports that show the maximum and average usage 
for Logical Devices (LDVs), AMP Vprocs, and PE Vprocs on the associated 
system. The NODE command is used to run NODE usage macros on the 
associated Teradata RDBMS. In addition, you can request coexistence reports 
that support mixed platform systems.

Procedure

To create the Historical Resource Usage Reports, do the following:

Note:  Running the Resource History macros can take several minutes, 
depending on the size of the table being searched and the load on the 
associated Teradata RDBMS. You can continue doing other Teradata Manager 
activities while you wait.

Step Action

1 Select Production Control > Resource History from the Executive menu bar. 

2 Choose one of the commands from the View menu on the Resource History 
menu bar. 

If your site is running a mixed platform system, you can choose one of the 
commands from the CoExist Macro menu.

3 Enter a date for the period of time you want the report to cover. Dates can be 
actual dates (in yyyy/mm/dd format), or expressions (such as date-30).

4 Click OK to initiate the macro and display the report.

5 Print the results if desired by choosing File > Print, or save the results by 
choosing File > Save As. 
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Create Logon Statistics Reports

LogOnOff Usage presents daily, weekly, and monthly logon statistics based on 
information in the DBC LOGONOFF view on the associated Teradata RDBMS. 
Three macros are included with LogOnOff Usage to help you retrieve this 
information:

• DailyReport shows the number of logons across several days, either in ten-
minute or one-hour intervals, grouped by time interval and user.

• WeeklyReport summarizes all logons for the last ten weeks, grouped by 
week.

• MonthlyReport summarizes all logons over the last month (from 30 days 
previous to the current date) grouped by date.

Procedure

To create Logon Statistics Reports, do the following:

Step Action

1 Select Production Control > LogOnOff Usage from the Executive menu bar. 

2 Choose one of the macro commands from the View menu on the Logonoff 
Usage menu bar:

• DailyReport shows the number of logons across several days.
• WeeklyReport summarizes all logons for the last ten weeks.
• MonthlyReport summarizes all logons for the last month.

3 If you selected WeeklyReport or MonthlyReport, the report is generated 
without any additional input.

If you selected DailyReport, do the following:

• Enter the Begin Date and the End Date in the following form: 
yyyy/mm/dd. The default entries, date-1 and date, will result in a report 
for yesterday and today.

• Choose either 10 minutes or Hour as the interval for the output.
• Click OK to initiate the macro and display the report.

4 Print the results if desired by choosing File > Print, or save the results by 
choosing File > Save As. 
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Create Performance Charts Using Teradata 
Performance Monitor

Teradata Performance Monitor is the Teradata Manager application that you 
use to monitor the general health of a Teradata RDBMS.  It also allows you to 
analyze current performance and both current and historical session 
information, and to abort sessions that are causing system problems.

Procedure

To create a chart showing the general health of your system, do the following:

Step Action

1 Select Performance > Teradata Performance Monitor from the Executive menu 
bar. 

2 Select File > Logon from the Teradata Performance Monitor menu bar. If in 
Client/Server mode, select a Teradata Manager server from the displayed 
list.

3 Once Teradata Performance Monitor has logged on, select View > Start from 
the menu bar, or click the Start button to display the data.

4 Select View > Chart from the menu bar, or click the Chart button to display 
the Chart dialog.

5 Select the data points you want charted. The chart will update automatically 
at the defined refresh rate. (The refresh rate is defined by selecting Tools > 
Options and selecting the Start tab).

6 To change the time period displayed on the chart, increase or decrease the 
number in the Intervals field. The total time covered by the chart is the 
number of intervals multiplied by the interval duration.  The interval 
duration is the Refresh Rate specified on the Start tab of the Options screen.

7 To change the color of a charted value, click on the color next to the charted 
value, then select a new color from the Select Color dialog box. (An alternate 
way to do this is to select the charted value, then choose View > Select Color 
from the menu bar. You can then choose a new color from the Select Color 
dialog box.)

8 To update the chart with the new data points instantly (before the specified 
update interval), click Redraw.
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Create Performance Charts Using DUC

Dynamic Utilization Charting (using PM & PC), or DUC (using PM & PC), 
displays near real-time Teradata RDBMS resource usage data in chart format on 
your Teradata Manager PC. You can set the frequency at which the charts are 
updated. The update frequency range is 6 to 3600 seconds while the system is 
running.

The charts can help you:

• Detect down nodes and down Vprocs
• Detect resource usage abnormalities on the associated Teradata RDBMS, 

such as the CPU Parallelism among Vprocs and Nodes

Procedure

To create the Performance Charts, do the following:

When you select a chart, DUC (using PM & PC) will activate and draw the 
chart. If you select it again, DUC (using PM & PC) will redraw the existing 
window.

If you select a chart other than the one currently displayed on the screen, DUC 
(using PM & PC) will display the newly activated chart in addition to the 
existing one.

Step Action

1 From the Executive menu bar, select Performance > DUC (using PMPC).

2 Once the application starts, select from the following on the Charts menu:

• All Charts displays all of the following six charts simultaneously. 
• All AMP Vprocs CPU Usage shows the percentage of CPU usage for each 

AMP of the nodes.
• All PE Vprocs CPU Usage shows the percentage of CPU usage for each PE 

of the nodes.
• All Nodes CPU Usage shows the percentage of CPU usage for each node.
• All Nodes Disk Usage shows the percentage of Disk usage for each node.
• Down Vprocs shows the number of AMPs and PEs that are down on the 

associated Teradata RDBMS.
• Down Nodes shows the down nodes numbers on the associated Teradata 

RDBMS.
Teradata Manager Getting Started Guide 4 – 7



Chapter 4: Creating Charts and Reports
Create Locking Logger Reports
Create Locking Logger Reports

The Teradata Manager Locking Logger application is a menu-driven interface 
to the Locking Logger (dumplocklog) console utility of the Teradata RDBMS 
software. 

When the RDBMS Locking Logger option (general GDO flag) is enabled, the 
Teradata RDBMS maintains ongoing logs of:

• Transaction Identifiers
• Session Identifiers 
• Lock Object Identifiers
• Lock Levels associated with executing SQL statements which have been 

delayed because of database lock contention

To create the report, Locking Logger joins your Lock Log Table with the system 
DBC.EventLog table to determine the blocked and blocking user names. To do 
this, it uses the begindate/time information from your lock log table and the 
logondate/time information from the DBC.EventLog table.

Procedure

Before you can generate a Locking Logger report, you need to create a Lock Log 
table as follows:

Step Action

1 Select Production Control > Locking Logger from the Executive menu bar. 

2 Maximize the Locking Logger main window so you can see any messages 
displayed in the status bar.

3 From the Locking Logger menu bar, select Tools > Create Table.

4 Type the name of your log table in the Log Table Name box, or accept the 
default name. You can specify an existing table or a new table (the Locking 
Logger utility will create it for you). 

In either case, your logon username must have the appropriate database 
access privileges.

a To specify a table under a database other than the default database of 
your logon username, enter both the database name and the table name 
as follows:

<db_name>.<table_name>

b To specify a table that is under the default database of your logon 
username, enter only the table name as follows:

<table_name>

Note:  The table name will be truncated to 30 characters.
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5 Select snapshot or continuous mode. If you selected snapshot mode, do one 
of the following:

• To use all available sessions to create or update your lock log table, check 
the SQL Sessions Maximum check box 

• To specify the number of SQL sessions that the Locking Logger utility 
will use, uncheck the Maximum check box and enter the desired number 
in the SQL Sessions field.  The minimum number of sessions is 1; the 
maximum is the total number of system AMP Vprocs that are online--one 
session per online AMP Vproc. If the selected number is greater than the 
actual number of sessions available (because a Vproc is offline), an error 
will result.

6 Optionally, use the Beginning / Ending Date and Beginning / Ending Time fields 
of the Time Constraints box to specify a time period for selecting lock log 
entries. The time constraints that you can select are:

• All entries that were created at or after a specified time. To specify this 
time constraint, enter the date and time in the Beginning boxes and leave 
the Ending boxes blank.

• All entries that were created at or before a specified time. To specify this 
time constraint, enter the date and time in the Ending boxes and leave the 
Beginning boxes blank.

• All entries that were created within a range of times. To specify this time 
constraint, enter both the Beginning and Ending dates and times.

If you do not specify a time period, all lock log entries that are related to the 
selected objects will be selected regardless of the time.

Step Action
Teradata Manager Getting Started Guide 4 – 9



Chapter 4: Creating Charts and Reports
Create Locking Logger Reports
7 Use the Database, Table, and Selected Objects list boxes to specify up to ten 
database object constraints for selecting lock entries. Teradata Manager adds 
the selections that you make to the Selected Objects box. 

• You can add an object to the Selected Objects list by either double-clicking 
on the object in the Tables list or by highlighting one or more objects and 
clicking Add.

• You can remove an object from the Selected Objects list at any time by 
either double-clicking on the object or by highlighting one or more 
objects and clicking and clicking Remove.

• To specify all tables in all databases, select All Objects. Teradata Manager 
will display an asterisk (*) in the Selected Objects list box and disable the 
Database and Table list boxes.

• To specify all tables under a selected database, first, if they are selected, 
deselect All Objects and Default Database. Then select the database that 
you want from the Database list and click All Tables.

• To specify a specific table under the default database, first, if it is selected, 
deselect All Objects. Then, select Default Database and select a table from 
the Table list.

• To specify a specific table under a database other than the default 
database, first, if they are selected, deselect All Objects and Default 
Database. Then select the database that you want from the Databases list 
and select a table from the Table list.

8 To initiate the Locking Logger console utility and create the table that you 
have specified, click on Submit. The minimum information required to 
enable the Submit button is a Log Table Name and one item in the Selected 
Objects list.

If you specified a new lock log table name, a confirmation box asks if you 
want to create the new table. Click Yes to continue.

9 After initiating the Locking Logger console utility click on Close at any time 
to re-enable the menu items. Locking Logger displays messages on the main 
window status bar about the work it is doing, ending with the number of 
rows it inserted into the Lock Log Table. The number of rows is also written 
to the Executive log.

• If you specified snapshot mode, 
– if you did not close the Create Table dialog, the Submit button will be re-

enabled when the work is complete.
– the Locking Logger console utility terminates automatically after 

completing the operation.
• If you specified the continuous mode, the Locking Logger console utility 

runs continuously until you stop it by selecting the Stop Logging option 
from the Logging Menu.

Step Action
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Procedure

Now that you have created a Lock Log table, you can generate a Locking 
Logger report, as follows:

Step Action

1 If Locking Logger is not running, select Production Control > Locking Logger 
from the Executive menu bar. 

2 From the Locking Logger menu bar, select Tools > Generate Report.

3 Enter the name of the lock log table in the Log Table Name box, or accept the 
default table name.

4 Enter the Beginning and Ending Dates, or accept the defaults.

5 Enter the Beginning and Ending Times, or accept the defaults.

6 Click on Generate to produce the report. Locking Logger opens an empty 
document, displays messages on the main window status bar about the work 
it is doing, then finally formats the report in the open document.
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Chapter 5: 

Performing Administrative Tasks

Teradata Manager provides you with lots of system administration options. 
This chapter shows you how to:

• Administer Sessions 
• Display and Administer Statistics for Tables and Databases 
• Monitor and Move Database Space 
• Maintain and Monitor System Tables 
• Create Databases, Tables and Users 
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Administer Sessions

Session Information (SI) uses the PM Data Collector to collect the session PM & 
PC data from the Teradata RDBMS.  It then formats and displays key 
information about each session, based on the current collection rate. SI shows 
logon sessions in different categories, and helps you to identify blocked and 
long idle sessions and abort sessions as desired on the Teradata RDBMS.

Session Information Reports

Most of the SI reports are categorized based on the session’s status.  These 
reports can be used in many different ways. You can open the reports based on 
your needs, and set up the desired Collection Frequency. Once this is done SI 
will update the reports automatically. 

The following reports provide very useful information, and you may wish to 
leave them open all the time.

Summary Report

This report gives you a general idea of how many sessions are logged on to the 
system and their status.

Blocked Report

If there is a blocked session, it will be displayed in this report.  Double clicking 
on the blocked session in the report displays the Host/Session detail dialog.  
This dialog shows who is blocking the session, and allows you to examine how 
many sessions are being blocked. You can also use the Host/Session dialog to 
abort the session.

Idle Report

You can define thresholds for the Idle report so that all long idle sessions will be 
displayed in this report.  You can also define the Auto Abort Threshold so that 
the long idle sessions will abort automatically.  It is recommended that a local 
filter be defined and used with this report in order to avoid aborting critical 
sessions/users. 

Procedure

To view Session Information reports and/or abort sessions, do the following:

Step Action

1 Select Production Control > Session Information from the Executive menu bar. 

2 Select the report(s) that you want to view from the Report Type pulldown list.
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3 From all report types except the Summary Report, you can double-click on 
any session in the report to display the Host/Session dialog.

4 From the Host/Session dialog, you can do the following:

• Click Modify to change the account string either for only the currently 
running request, or for all requests. This allows the priority to be changed 
while the session is active.

• Click Abort to display a dialog allowing you to abort the selected session 
or all sessions associated with either the host or the user name of the 
selected session.

• Click Blocked to get information about the session(s) that are blocking the 
displayed session.

• Click Blocking to get a list of the session(s) being blocked by the displayed 
session.

• Click Skew to view detailed CPU and disk usage information for the 
current session.
Note:  This option is only available when monitoring a V2R4.1 or later 
Teradata system.

• Click SQL to view the SQL statements currently being executed by this 
session. You can also see job step information and associated Explain text. 
Note:  This option is only available when monitoring a V2R4.1 or later 
Teradata system, and the selected session is logged onto the DBC/SQL 
partition.

Step Action
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Display and Administer Statistics for 
Tables and Databases

Collecting statistics on a column or Key field assists the query optimizer in 
choosing an execution plan that will minimize query time. Because the 
optimizer bases the execution plan on the actual values in the table, statistics 
should be updated whenever there have been a significant number of row 
additions or deletions.

Statistics Collection allows you to:

• Determine which tables have statistics
• Create statistics for columns or indexes
• Drop statistics by column/index, or for the entire table
• Update statistics for column/index, table, database, or the entire Teradata 

RDBMS

This application can also help you create SQL scripts to collect/drop statistics 
and set up the Autostart menu.

Procedure

To view statistics for your database, do the following:

Step Action

1 Select Production Control > Statistics Collection from the Executive menu bar. 

2 When the Statistics application opens, the Database pane is displayed. This is 
a listing of all the databases on the system. Click on a database icon to see the 
children of that database and to retrieve the associated tables.

• If there are no databases below the one selected, the table data for that 
database is displayed in the Table pane. 

• If there is a database below the one you selected, the tree view will 
expand to display it.

3 The Tables pane lists the tables contained in the selected database. Double-
click on the desired item in the Table pane to display the column statistics in 
the Column pane.

4 The Statistics pane shows statistics for the selected database/table. Double-
click on the desired item in the Column pane to display the Interval Statistics 
for that item.
Teradata Manager Getting Started Guide5 – 4



Chapter 5: Performing Administrative Tasks
Monitor and Move Database Space
Monitor and Move Database Space

Space Usage is the Teradata Manager application that you use to monitor the 
use of database space on the associated Teradata RDBMS computer and to 
reallocate permanent space from one database to another.

Space Usage has some functionality overlap with WinDDI. Both Space Usage 
and WinDDI provide capabilities to move permanent space between databases 
and to view the database hierarchy and space utilization reports. Space Usage 
offers a richer set of reports specifically for monitoring database space usage on 
the Teradata RDBMS. Space Usage also contains direct support for changing 
the database hierarchy (via Move Database command).

Procedure

To view a Space Usage Report, do the following:

Step Action

1 Select Production Control > Space Usage from the Executive menu bar. 

2 From the Space Usage menu bar, select Tools > Space by Database. This will 
display a Space by Database report.

3 If you right-click on a database name, a popup menu is displayed with 
various options, including Table Space and Help Database reports. Select the 
Table Space option to display a Table Space Report.

4 If you right-click on a table name, a popup menu is displayed with various 
options, including Space by Vproc and Show Table reports. Select the Space by 
Vproc option to display a Space by Vproc Report.

5 Explore the other options under the Tools menu, including the Hierarchy and 
Cylinders by Vproc reports.
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Procedure

To reallocate permanent space, do the following:

Step Action

1 If Space Usage is not running, select Production Control > Space Usage from 
the Executive menu bar. 

2 Select Tools > Options from the menu bar to display the Options dialog and 
click on the Reports tab:

• To automatically refresh your Space Usage reports after each move space 
operation, click on the Reports tab, and select the Automatically Refresh 
Reports after each Move Space check box.

• To enable an audible notification that the refresh operation has 
completed, select the Sound when Refresh Reports completes check box.

3 Click on the Move Space tab:

• Use the Default Amount to Move field to specify the amount of disk space 
you want to reallocate. The amount must be a whole number without 
commas, periods, or abbreviations.

• Select Show all databases to list all databases on the associated Teradata 
RDBMS computer. If this item is unchecked, then the Only show databases 
for which… options become enabled.

• Selecting the option to only show databases for which the Maximum Perm 
>= Amount To Move will display only those databases with an amount of 
maximum permanent disk space that is equal to or greater than the 
amount you specified in the Default Amount to Move entry box.

• Selecting the option to only show databases for which the Unused Perm 
>= Amount To Move will display only those databases with an amount of 
unused permanent disk space that is equal to or greater than the amount 
you specified in the Default Amount to Move entry box.

• Select Order by Database Name if you want to sort the database list 
alphabetically by Database name in the From selection box on the Move 
Space dialog.

• Select Order by Maximum Perm Space if you want to sort the database list 
numerically by the amount of  Maximum perm space.

• Select Order by Unused Perm Space if you want to sort the database list 
numerically by the amount of  Unused perm space.

• The entry displayed in the User ID field is the default User Id for the 
profile that Space Usage is running under.  Either accept the default User 
Id or enter an alternate one. If you enter an alternate User Id, you will be 
prompted for a password each time you try to move space.
Note:  If your site is set up for Single Sign On (SSO), you have the option 
to leave the User ID field blank. If you do this, you will be prompted for 
an ID and password each time you try to move space.

• The entry displayed in the Account field is the default Account Id for the 
profile that Space Usage is running under.  Either accept the default 
Account Id or enter an alternate one. If you enter an alternate Account Id, 
you will be prompted for a password each time you try to move space.
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The Space Usage status bar indicates the progress of the move space operation 
while it is taking place.

4 Click OK to save your entries and close the Options dialog.

5 Select Tools > Move Space from the menu bar to display the Move Space 
dialog.

6 Use the From selection box to specify a source database.

7 Use the To selection box to specify a destination database.

8 Click OK to initiate the move space operation.

9 Click OK in response to the confirmation prompt.

Step Action
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Maintain and Monitor System Tables

System Maintenance allows you to run the macros needed to maintain and 
monitor system tables. The commands used to delete rows in system tables and 
to reset accounting statistics for AMP usage and disk space are invoked from 
the Clean menu.  Other system monitoring and reporting commands are found 
in the Configuration and Audit menus.

Procedure

To run a clean macro in order to remove rows of data from specified system 
tables, do the following:

Step Action

1 Select Production Control > System Maintenance from the Executive menu bar. 

2 From the System Maintenance menu bar, select Clean > System Tables.

3 Select a macro from the list box in the Select Clean Macro to Execute dialog. 

The list box contains only the macros listed using the SM_CleanMacros 
application-specific entry in the associated profile.  The Clean macros 
provided with System Maintenance include:

• Macros to clean the Error Logs
• A macro to clean the Logonoff Table
• Macros to clean the Resusage Tables
• A macro to clean the SecurityLog Table.

4 Enter the beginning and ending dates in the Begin Date and End Date boxes.  

Note:  Dates can be actual dates (in yyyy/mm/dd format), or expressions 
(such as date-30).

5 Click OK to start execution. 

6 If you have the Warning Preference set on, a warning message appears on 
the screen. Click Yes to run the macro.

When the macro has finished running, the output window shows the 
number of rows deleted.  If the macro encounters an error, the output 
window shows the error number.

7 Click Exit to close the Select Clean Macro dialog.
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Create Databases, Tables and Users

WinDDI (Windows Data Dictionary Interface) is the Teradata Manager 
application that you use to perform database administration tasks.

Logging On

To Log on to the desired database, do the following:

Create Or Modify a Database

To create or modify a database, do the following:

Step Action

1 Select Tools > WinDDI from the Executive menu bar. 

2 Select the desired data source options and click OK.

3 Fill in the Connect dialog and click OK to log on to the database.

Step Action

1 Log on to the desired data source using the Logging On procedure above. 

2 To create an entirely new database, with no shared specifications from an 
existing database:

a Select Tools > Create Database from the menu bar.
b Use the Create Database Dialog  to define the attributes of the new 

database.
c Click OK when finished.

To create a new database that is either identical or closely related to an 
existing database:

a Select Tools > Clone Database from the menu bar.
b Use the Create Database Dialog  to define the attributes of the cloned 

database.
c Click OK when finished.

To change the specifications of an existing database:

a Select Tools > Modify Database from the menu bar.
b Use the Modify Database Dialog to modify the attributes of the database.
c Click OK when finished.
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Create or Modify a User

To create or modify a user, do the following:

Create a Table

To create a table, do the following:

Step Action

1 Log on to the desired data source using the Logging On procedure above. 

2 To create an entirely new user, with no shared specifications from an existing 
user:

a Select Tools > Create User from the menu bar.
b Use the Create User Dialog to define the attributes of the new user.
c Click OK when finished.

To create a new user either identical or closely related to an existing user:

a Select Tools > Clone User from the menu bar. The Create User dialog 
displays the specifications for the currently selected user.

b Use the Create User Dialog to change the specification for your cloned 
version of the existing user.

c Click OK when finished.

To change the specifications of an existing user:

a Select Tools > Modify User from the menu bar.
b Use the Modify User Dialog to change the attributes of the selected user.
c Click OK when finished.

Step Action

1 Log on to the desired data source using the Logging On procedure above. 

2 To create a new table in Teradata format:

a Select Tools > Create Table from the menu bar.
b Use the Create Table Dialog to define the attributes of the new table.
c Click OK when finished.
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The Performance Monitor Object

This chapter describes the Teradata Performance Monitor Object, and contains 
the following sections:

• Introduction to the Performance Monitor Object 
• Application Distribution Requirements 
• The Object Model 
• Object Model Error Messages 
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Introduction to the Performance Monitor 
Object

The Performance Monitor Object is an ActiveX (COM) object that exposes 
methods to allow retrieval of PM & PC data. Each method will return a 
collection of objects, each of which encapsulates the performance data for that 
object. It also provides for execution of the production control (action) 
functions of PM & PC.

Before You Start

The Performance Monitor object can be run in both Visual Basic (VB) and C++ 
environments.

• To use this object in a new VB program you must use the Project, References 
menu to add a reference to it. You will find it in the listbox under 
TeradataPerformance3. For more information on using the Monitor Object 
with VB, please refer to the sample code in 
\<install_directory>\Samples\VB\SimpleMon.

• To use this object in C++, you will need to include the files TDMon.h and 
TDMon_i.c into your source code. These files can be found in 
\<install_directory>\Samples\VC\Simpmon. Your code must call the 
function CoInitialize() to prepare for the use of COM objects. For more 
information please refer to the sample application in the directory 
mentioned above.

You will need to add the \<install_directory>\Bin directory to your path if you 
are not executing all components from within this directory (this applies during 
debugging also). This will allow the object to find its required support files.

Object Modes

The Monitor object can be used in 2 modes. The mode is controlled by the 
setting of the UseClient property. Initially UseClient will be set to False.

Direct mode

In direct mode all data is fetched directly from the Teradata RDBMS.  You must 
establish a session using the Connect method before calling any of the data 
retrieval or action methods.

Client mode

Initially in Client mode, a RDBMS session is temporarily established in order to 
retrieve some control information. Once this information is obtained, the 
session is disconnected and all future data is retrieved from a Teradata 
Manager server.  You do not need to establish a session on the Teradata 
RDBMS.
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You start client mode by setting UseClient = True. This will fail if 
communication can not be established with a Teradata Manager server. You 
should therefore check the value of the UseClient property, after setting it, to 
ensure that it has been successfully set to True.

When you set UseClient to True, a tmclient application will be launched on 
your workstation. This will normally display a selection list for you to choose 
the Teradata Manager server you wish to use. If you wish to run in unattended 
mode you may set the AutoClient property to True before setting UseClient to 
True. This will cause the server name to be read from the registry. In order to 
use this feature you must previously have saved the server name to the registry. 
This can be done from the Select a Server dialog that is displayed when using 
Client mode in any of the Client capable applications. (Session Information, 
Teradata Performance Monitor, Dynamic Utilization Charting, or any 
application using the Monitor object.)

Object Scope

In general you will want to create a Monitor object at application startup and 
destroy it (In VB set the object = Nothing) at program termination. The 
GetSessionData function uses an internal cache that allows the object to 
calculate CurrentCPU, Time Blocked, and Time Idle. If you destroy and re-
create the object these values will keep resetting to zero. This internal cache 
applies only when running in Direct mode. Although the object will take care 
of DisConnect and Client Shutdown when it is destroyed, it is good practice to 
specifically call Disconnect, or to set UseClient to False. 

Sample Files

There are sample files included with the Teradata Manager installation to help 
you get started with the Object Model. You can find these samples in 
\<install_directory>\Samples.
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Application Distribution Requirements

You can run the object model in both Client and Direct modes on any machine 
that has Teradata Manager installed. 

Required Files

If you would like to run the application on a machine that does not have 
Teradata Manager installed, you can run in Direct mode with the following files 
installed on your machine.

Note:  The required versions of these support files are distributed with the 
current release of Teradata Manager.

File Registration

In addition to having the above files on your machine, you also need to register 
the TDMon3.dll by executing the following command.

regsvr32 tdmon3.dll

Note:  The application regsvr32.exe is a Microsoft application. The file 
TDMon3.dll must be prefixed by its full path if the command is not executed 
from within the directory that contains the file.

Required Microsoft Support Files

asycfilt.dll
comcat.dll
mfc42.dll
msvbm60.dll
msvcirt.dll
msvcrt.dll
msvcrt40.dll
oleaut32.dll
olepro32.dll
stdole2.tlb

Required Teradata Manager Support Files

dbsm_ipc.dll
mgrcli.dll
monpm.dll
ncrvbext.dll
regkey.dll
tmipc.dll
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The Object Model

This section describes the makeup of the Object Model. When reading the 
model descriptions, note that the fonts have these meanings:

The Object Model is made up of the following objects:

Font Meaning

Plain Property

Italic Read Only Property (optional parameter)

Bold Method

Monitor (Object)

AppName
System
UserId
Password
UseClient
AutoClient
IdNames

Connect (System, UserName, Password)
DisConnect ()
GetVprocSummary () (returns a VprocSummary object)
GetNodeSummary () (returns a NodeSummary object)
GetVprocDetail (PEs) (returns an AMPs collection) 
GetNodeDetail () (returns a Nodes collection)
GetSessionData (HostID) (returns a Sessions collection) 
GetSessionSQL
AbortSession (HostID, SessionOrUserName)
ModifyAccount (HostID, SessionNum, NewAccount, CurrentRqstOnly)
MonitorVersion
SetNodeMonitorRate (Rate)
SetVprocLoggingRate (Rate)
SetVprocMonitorRate (Rate)
SetNodeLoggingRate (Rate)
SetSessionRate (Rate, SetLocalRate)

Connected
Profile
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VprocSummary (Not Creatable)

AvgAMPUse
AvgPEUse
AvgDiskUse
AvgDiskIOs
HiAmpUse
HiAmpNode
HiAmp
LoAmpUse
LoAmpNode
LoAmp
HiPeUse
HiPeNode
HiPe
LoPeUse
LoPeNode
LoPe
HiDiskUse
HiDiskNode
HiDiskAmp
LoDiskUse
LoDiskNode
LoDiskAmp

NodeSummary (Not Creatable)

AvgDiskUse
AvgDiskIOs
HiCPUUse
HiCPUNode
LoCPUUse
LoCPUNode
HiDiskUse
HiDiskNode
LoDiskUse
LoDiskIOs
LoDiskIONode
AvgBynetUse
BynetAStatus
BynetBStatus
NodeLoggingRate
NodeMonitorRate
LoDiskNode
LoDiskAmp

Version
TDRelease
HiDiskIOs
HiDiskIONode
HiDiskIOAmp
LoDiskIOs
LoDiskIONode
LoDiskIOAmp
SessionCount
SessionRateLocal
SessionRateSystem
VprocLoggingRate
VprocMonitorRate
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AMPs (Collection / Not Creatable)

AvgCpuUse
MaxCpuUse
ParallelEfficiency
BynetAStatus
BynetBStatus
MonitorRate
Count
Item

AMP (Object)

Key (AMP Number)
NodeId
Status
CpuUse
AmpWorkerUse
SystemUse
DiskUse
DiskReads
DiskWrites
AvgDiskRequests
MemSegsAllocated
MemKBAllocated
NetReads
NetWrites
Cluster
RunCount
BackupSegsAllocated

PEs (Collection / Not Creatable)

AvgCpuUse
MaxCpuUse
Count
Item
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PE Object

Key (PE Number)
NodeId
Status
HostId
LogonCount
RunCount
CpuUse
SystemUse
ParserUse
DispatcherUse
CICUse
HostReads
HostWrites
MemSegsAllocated
MemKBAllocated
NetReads
NetWrites

Nodes (Collection / Not Creatable)

AvgCpuUse
MaxCpuUse
AvgDiskUse
MaxDiskUse
AvgBynetUse
ParallelEfficiency
BynetAStatus
BynetBStatus
MonitorRate
Count
Item
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Node (Object)

Key (Node Id)
AmpCount
PeCount
Status
CpuUse
IOWaitUse
SystemUse
UserUse
BynetAUse
BynetBUse
DiskUse
CICUse
DiskReads
DiskWrites
AvgDiskRequests
HostReads
HostWrites
SwapReads
SwapWrites
SwapDrops
MemSegsAllocated
MemKBAllocated
MemAllocateFailed
MemSegsAged
NetReads
NetWrites
BackupSegsAllocated
BackupKBAllocated
BackupSegsAged

Sessions (Collection / Not Creatable)

MonitorRate
Count
Item
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The Object Model
Session (Object)

Key (HostId/Session)
SessionNum
HostId
UserName
Partition
Priority
Account
LogonPE
RunVproc
LogonDateTime
LogonSequence
LogonSource
PEState
AMPState
TotalPeCpu
TotalAmpCpu
TotalAmpIO
CurrentAmpCpu
DeltaSpool
TempSpace
TransactionCount
RequestCount
RequestCacheHits
TimeIdle
TimeBlocked
MoreBlockers
AmpCount
AmpSkew
DiskSkew

AvgAmpCpu
AvgDiskIO
HighAmpCpu1
HighAmpCpu2
HighAmpCpu3
LowAmpCpu1
LowAmpCpu2
LowAmpCpu3
HighAmp1
HighAmp2
HighAmp3
LowAmp1
LowAmp2
LowAmp3
HighDiskIO1
HighDiskIO2
HighDiskIO3
LowDiskIO1
LowDiskIO2
LowDiskIO3
HighDiskAmp1
HighDiskAmp2
HighDiskAmp3
LowDiskAmp1
LowDiskAmp2
LowDiskAmp2

Blocks (Collection / Not Creatable)

Count
Item
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The Object Model
Block (Object)

SessionNum
HostId
Severity
LockType
Granted
UserName
DbName
TableName
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Object Model Error Messages

The following table describes the possible error messages that may be 
generated by running the Performance Monitor.

Note:    Messages between 10000 and 19999 are 4 digit Teradata Error codes 
with a “1” appended at the start.  For example, Message 12345 would be 
returned for Teradata Error code 2345. 

Error Code Message

20001 WinCLI not found

20002 Already connected

20003 System, UserId or Password is not set

20008 The system can not be changed when running under a Teradata 
Manager profile

20009 Your application must have been launched by Teradata Manager to 
use Client mode

20010 Parameter 2 must be the session number (Long) or UserName (String)

20011 Invalid parameter passed to ModifyAccount

20012 The Session rate must be in the range 6 to 3600, or 0

20013 The Resource rate must be an integer divisor of 3600, or 0

20014 You are not connected to a Teradata system

20015 You are not connected to a Teradata system, or using Client mode
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Teradata Manager Alerts

This chapter explains the setup and usage of the Alerts system.

Alerts provides you with a single vantage point for monitoring the overall 
system performance of one or more Teradata RDBMS systems. In addition to 
viewing system performance, you can set the Alerts system to automatically 
take user-defined actions when defined limits are exceeded. Using the simple 
graphical interface, you can easily drill down from an overall picture to identify 
problem areas, using this information to prevent hazard situations.

The Alerts system also provides a performance status graphing function, 
allowing you to display a graph showing system performance by simply 
clicking on any data point value. 

This chapter shows you how to:

• Set Up an Alert Policy 
• Start the Alert Control Module 
• Display the Performance Status of the RDBMS 
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Set Up an Alert Policy

The key to the Alerts system is the user-defined action. An action can consist of 
various tasks, such as paging a systems programmer, sending an Email to a 
customer support center, displaying a banner, or running an executable 
program that automatically corrects a problem.

Once the actions are defined, you can define the events that trigger them. 
Events occur when a monitored system parameter crosses a threshold that you 
have defined. These events are defined based on data collected from the 
following areas:

• PM Physical Resource data
• PM Virtual Resource data
• Database Space information
• Session information
• Teradata messages
• Event Combinations

The combination of action and event definitions is called an Alert Policy, and is 
created using the Alert Policy Editor.
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Create a New Policy

To create an Alert Policy, complete the following procedure:

Step Action

1 Start the Executive and log on to the Teradata RDBMS you will be working 
with. See “Start The Executive” on page 2-9 for instructions.

2 Select Tools > Alert Policy Editor from the Executive menu bar. The Alert Policy 
Editor starts and displays the following window.
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Add Actions to the Policy

Actions are the first thing you need to add to the Policy. Actions are the steps 
that the system takes when the system performance falls outside of the 
specified limits. Actions must be defined before setting any system limits.

3 To create a new policy based on the Alert Policy Template, select File > New 
from the Alert Policy Editor menu bar. This displays the Create Alert Policy 
dialog box.

Note: To create a new policy based on an existing one, click the Local or 
Active button on the main window of the Alert Policy Editor, then click on a 
name in the list. Select File > Save As, and save the policy with the new name.

4 Enter a name for the new Alert Policy, then click OK.

The Alert Policy Editor creates a new Policy based on the Alert Policy 
Template.

Step Action
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Set Up an Alert Policy
To create an Action, complete the following procedure:

Step Action

1 Click on the Actions tab to make it active, then click Add. This displays the 
Add Action dialog box.

2 Enter a name for the action, and make sure that the Action Definition option is 
selected, then click OK. The new name appears in the list of actions.

3 Make sure the action name is highlighted in the list, then use the Physical 
Action list to select the appropriate type of action.

4 The fields below the selected Physical Action will change depending on your 
selection. Fill them in as necessary.

You can change the value in the Do not repeat within field to set the amount of 
time the system waits before repeating the Physical Action.

5 Repeat this procedure from step one to add as many actions as are required.
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6 If you wish to add an action that consists of several sub-actions, click Add. 
This displays the Add Action dialog box.

7 Enter a name for the action, and make sure that List of Actions is selected, then 
click OK. The new name appears in the list of actions.

Step Action
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Set Up an Alert Policy
Add Database Space Events to the Policy

Database Space events are defined to raise an alert whenever the space used on 
any AMP exceeds the specified percentage. Make sure you have defined the 
appropriate actions before continuing.

8 Make sure the List of Actions name is highlighted in the list, then click Add 
under the List of Actions. This displays the Add Actions to List dialog box.

9 Hold down the Ctrl key and select the actions you would like to be grouped 
under the List of Actions, then click OK. The actions you selected are now 
displayed in the List of Actions.

Step Action
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To add a Database Space event, complete the following procedure:

Step Action

1 Click on the DB Space tab to make it active, then click Add. This displays the 
Add Database Rule dialog box.

2 Do one of the following:

• To apply the rule to a specific database, click Apply to specific database, then 
enter the name of the database in the Database name field.

• To apply the rule globally to all databases, click Apply to all databases.

Click OK to add the new database rule to the list.

3 Make sure the rule is highlighted, then enter the desired percentage limit in 
the % Space used is above field.

4 With the same rule highlighted, use the pulldown list to select the desired 
action to be taken when the rule is exceeded.

5 Repeat this procedure from step one to add as many rules as are required.
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Set Up an Alert Policy
Add System Level Performance Events to the Policy

To add a System level performance event, complete the following procedure:

Step Action

1 Click on the System tab to make it active.

2 Click on the desired event, then use the Above and Below fields to set the 
system limits.

3 Use the pulldown menus to define the appropriate actions to take for the 
Above, Between, and Below conditions.

4 Repeat this procedure from step two to set up as many System level events as 
are required.
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Set Up an Alert Policy
Add Node Level Performance Events to the Policy

To add a Node level performance event, complete the following procedure:

Step Action

1 Click on the Nodes tab to make it active.

2 Click on the desired event, then use the Above and Below or Count fields to set 
the system limits.

3 Use the pulldown menus to define the appropriate actions to take for the 
Above, Between, and Below conditions.

4 Repeat this procedure from step two to set up as many Node level events as 
are required.
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Set Up an Alert Policy
Add Vproc Level Performance Events to the Policy

To add a Vproc level performance event, complete the following procedure:

Step Action

1 Click on the Vprocs tab to make it active.

2 Click on the desired event, then use the Above and Below fields to set the 
system limits.

Note: The Vproc is Down event is a simple condition, and thus has no limit 
fields attached to it.

3 Use the pulldown menus to define the appropriate actions to take for the 
Above, Between, and Below conditions.

4 Repeat this procedure from step two to set up as many Vproc level events as 
are required.
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Set Up an Alert Policy
Define Data Collection Rates for the Policy

To define data collection rates, complete the following procedure:

Step Action

1 Click on the Rates tab to make it active.

2 Highlight the appropriate collection type, then change the collection 
frequency by entering the new value in the Collection Interval box.

• The Refresh Policy Information rate is the frequency at which the Alert 
Control Module checks to see if the active policy has been updated, and if 
so, notifies the collectors to refresh their copy of the policy.

• The Process Alert Requests rate is the frequency at which the Alert 
Control Module checks to see if alerts need to be raised for the user jobs. 
The criteria for alerts is based on the rows that have been inserted into the 
Alert Request and Monitor Request tables.

3 Repeat step two to set up as many rates as are required.

4 Now that you have seen how the Alert Policy Editor tab dialog works, you 
can set up any additional alert parameters by selecting the appropriate tab 
and filling in the fields.
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Set Up an Alert Policy
Save and Apply the Policy to the RDBMS

To save the new policy and apply it to the RDBMS, complete the following 
procedure:

Step Action

1 Select File > Save from the menu bar to save the policy.

2 If you want to apply the new policy to the database (make it an 
Active policy), select Tools > Apply to Database from the menu bar. 
This displays a list of profiles currently in the active list.

3 Select the desired profile from the list, then click OK to apply the 
Policy to the associated RDBMS.
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Start the Alert Control Module

Before running the Alert Viewer, you must first start the Alert Control Module 
(ACM). ACM will in turn start the necessary Data Collectors, enabling the 
Alerts system to monitor the status of the Teradata RDBMS.

Start the Alert Control Module

Follow this procedure to start the Alert Control Module:

Step Action

1 Start the Executive and log on to the Teradata RDBMS you will be working 
with. See “Start The Executive” on page 2-9 for instructions.

2 Select Tools > Alert Control Module from the Executive menu bar. The Alert 
Control Module starts, logs on to the database, and displays the following 
window.
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Display the Performance Status of the 
RDBMS

Once you have set up an Alert Policy and started the Alert Control Module, 
you are ready to use the Alert Viewer to display the status of the RDBMS. 

Start the Alert Viewer

Follow this procedure to start the Alert Viewer:

Step Action

1 Make sure the Alert Control Module is running (see “Start the Alert Control 
Module” on page 7-14 for instructions).

2 Start the Alert Viewer by selecting Tools > Alert Viewer from the Executive 
menu bar. This displays the Modify Active List dialog box.

3 Move one or more profiles from the Available Profiles box to the Active 
Profiles box by first highlighting the item (highlight multiple items by 
holding Shift while clicking), then clicking Add. 
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4 Click OK. This displays the Servers Available dialog box.

Note:  A dialog box will appear for each profile in the Active list.

5 Select the desired server, then click OK. This displays the Alert Viewer main 
window.

Step Action
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6 The Alert Viewer window displays a tree structure containing your active 
profiles. To expand the tree view, click on a “+” sign next to a profile or 
group. To collapse the tree view, click on a ‘-’ sign.

Try the following:

• Click on each profile (displayed as a top-level item in the tree structure in 
the left window) to display the related system level data in the panel to 
the right. 

• Click on the second or third-level group items below each profile to show 
the actual item together with the associated detail data.

7 You can create a chart from any of the data points by doing one of the 
following:

• Move your cursor across the value fields on the main window. When the 
cursor changes to a “hand” shape (meaning the field contains chartable 
data) double-click on the field to create a chart.

• Select View > Chart from the menu bar, then select one of the chartable 
items from the Chart submenu to create a chart for that item.

Note: If the data for this profile is being charted for the first time, then the 
Alert Viewer will just open the graph window and draw the data. If the data 
is being charted for the second time (or more), the Viewer will pop up a Select 
Chart dialog box. This allows you to group the data any way you want if 
there are several charts associated with the one profile.

Step Action
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Chapter 8: 

Visual Explain

Visual Explain provides visual depictions of the execution plans chosen by the 
Teradata RDBMS Optimizer to access data. It does this by turning the output 
text of the EXPLAIN modifier into a series of easily readable icons. 

Visual Explain is especially useful in comparing the execution plans of similar 
queries. Using the compare feature allows you to easily resolve Optimizer 
related discrepancies.

Note:  The Query Capture Facility (QCF) must be installed on your RDBMS 
before running Visual Explain. For information about installing this feature, 
refer to Chapter 4 – “Query Capture Facility” of the Teradata RDBMS SQL 
Reference, Volume 2.

This chapter contains procedures on:

• Setting Up the Query Capture Database 
• Displaying an Execution Plan 
• Entering a Query and Viewing Its Execution Plan 
• Comparing Execution Plans Visually 
• Displaying Differences in Explain Text 
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Setting Up the Query Capture Database

Before running Visual Explain, you need to set up a Query Capture Database. 
This is easily done from inside Visual Explain.

Setting Up a New Query Capture Database

Follow this procedure to create a new Query Capture Database (QCD) on your 
system. 

Note:  If you have a QCD that was created prior to the latest Teradata RDBMS 
upgrade, you need to upgrade the QCD. For instructions, skip to the next 
procedure, “Upgrading an Existing Query Capture Database” on page 8-2.

Upgrading an Existing Query Capture Database

Follow this procedure if you need to upgrade an existing QCD database. You 
only need to do this if you have a QCD database that was created prior to the 
latest Teradata RDBMS upgrade,.

Step Action

1 Select Tools > Control Center from the menu bar.

2 Click the Manage QCD tab, then click the Setup QCD button.

3 Select the option Create all QCD database objects (tables and macros).

4 Enter a name for the QCD in the QCD Name field.

5 Enter an owner name in the Owner field. If this field is left blank, the owner 
defaults to the name of the logged on user.

6 Specify the Perm and Spool Space, selecting the appropriate units (KB, MB or 
GB) by clicking the desired option. (If no Perm Space is specified, the default 
is 1MB. If no Spool Space is specified, the default is 0.)

7 If you want the fallback option, check the Fallback check box.

8 If you want to view the schema of the Tables and Macros that will be created 
in the new QCD, click the View Schema button.

9 If you want to clear all fields to their default options, click Clear.

10 Click Create to set up the QCD.

Step Action

1 Select Tools > Control Center from the menu bar.

2 Click the Manage QCD tab, then click the Upgrade/Revert QCF Version 
button.
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3 Enter the name of the QCD in the Database Name field. The current version of 
QCF is displayed in the Present Version field.

4 Choose the version you want to change to by selecting it in the Intended 
Version field.

5 Click OK to begin the conversion.

Step Action
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Displaying an Execution Plan

What is exciting about Visual Explain is that it turns even the most complex 
textual explain statement into a flow diagram of easily recognized icons. 
Follow the steps below to use Visual Explain to display an execution plan 
inserted into the database.

Step 1:  Connecting to the Teradata RDBMS

The first step is to connect to the Teradata RDBMS.

Step 2:  Inserting an Execution Plan Into the QCD

In order to view an Execution Plan using Visual Explain, the plan must first be 
inserted into the Query Capture Database (QCD) using the SQL INSERT 
EXPLAIN command.

You can insert the query Execution Plan using other applications (BTEQWIN, 
Queryman, etc.), or you can run it from Visual Explain itself.

Use the following procedure if you want to insert the execution plan from the 
desired query into the QCD using Visual Explain.

Step Action

1 Select File > Connect from the menu bar.

2 Enter the following:

• RDBMS Name
• User Name
• Password
• Database Name (optional)
• Account String (optional)

3 Click OK to connect to the RDBMS.

Step Action

1 Select Tools > Execute SQL from the menu bar.

2 In the dialog that appears, do one of the following to execute a query 
containing the INSERT EXPLAIN statement:

• To select a query to be executed from a file, click Browse, and locate the 
file to be executed.

• Enter the text for the query in the Query window.

3 Click Execute. The results of the query are displayed in the Query Results area.
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Step 3:  Viewing the Execution Plan

Once the explain text for the query has been inserted into the QCD database 
(via the INSERT EXPLAIN statement, you can use Visual Explain to view the 
explain results graphically, or textually. 

Follow this procedure to view the execution plan:

Step Action

1 Once you are connected to the RDBMS, select File > Open Plan from Database 
from the menu bar. This displays the Select Execution Plans to Open dialog 
box.

2 Specify the Database from which you want to load the queries.

3 Do one of the following to select the desired queries from the selected 
database:

• To load all queries, enter the “%” character in the Query Tag field.
• To load a range of queries, enter the range in the Query ID field (for 

example, “1-100”).
• To load a specific query, enter the query tag in the Query Tag field, or the 

query id in the Query ID field.

4 Click Browse QCD to load the specified queries into the list of Available 
Execution Plans.

5 To load plans from additional servers, click Connect To.

6 To load offline plans, click Offline Plan.

7 To select plans for opening, in the Available Execution Plans list, click on the 
Select column of the desired plan(s). A check will mark the plan as selected.

8 Once the desired plans are selected, click Add to add the selected plan(s), to 
the Selected Execution Plans list. To add all available plans, click Add All.

9 Once the desired plan(s) are in the Selected list, click Open to display the 
plan(s).

To easily navigate around larger plans, select View > View Pad.

10 In addition to viewing the visual description of the plan, you can do the 
following:

• To view Statement text, select Plans > Statement Text from the menu bar.
• To view Explain text, select Plans > Explain Text from the menu bar.
• To view Step text, move the mouse pointer over the desired step number, 

click the right mouse button, and choose the Step Text option.
• To view summary information, select View > Summary Information.
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Entering a Query and Viewing Its 
Execution Plan

As an alternative to running a query using the INSERT EXPLAIN statement 
and then locating it and displaying the results, Visual Explain allows you to 
simply enter the statement text and immediately view the execution plan for 
that query. Use the following procedure to do this.

Step Action

1 Select Tools > Launch QCF from the menu bar.

2 Select one of the following options:

• If you want to insert the execution plan information into the specified 
QCD, select View Execution Plan (Insert Explain).

• If you want to capture the execution plan as a series of INSERT statements 
that can be saved to a BTEQ file and printed or inserted into the QCD, 
select Capture Execution Plan (Dump Explain).

3 If you have selected the Insert Explain option and you want the execution 
plan information deleted from the QCD once it is displayed, check the option 
Delete After Use.

4 Enter the name of the desired QCD database in the Database field.

5 Enter the desired name you want to use to identify the query in the Query 
Name field.

6 Do one of the following:

• If you want to enter the statement text, enter it in the Query window.
• If you want to open a file containing statement text, click Browse to locate 

the file.

7 If you want to recreate a system environment by setting the Cost Parameters 
and/or Random AMP Samples at session level, click Set/Reset.

8 Click Submit to create the execution plan.

To easily navigate around larger plans, select View > View Pad.

9 In addition to viewing the visual description of the plan, you can do the 
following:

• To view Statement text, select Plans > Statement Text from the menu bar.
• To view Explain text, select Plans > Explain Text from the menu bar.
• To view Step text, move the mouse pointer over the desired step number, 

click the right mouse button, and choose the Step Text option.
• To view summary information, select View > Summary Information.
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Comparing Execution Plans Visually

Now we’ll use Visual Explain to compare execution plans. This first 
comparison is visual, with the differences in plans highlighted by red arrows.

Step 1:  Loading the Execution Plans

Before you can compare execution plans, you first need to load them into 
Visual Explain. Do the following:

Step Action

1 Once you are connected to the RDBMS, select File > Open Plan from Database 
from the menu bar. This displays the Select Execution Plans to Open dialog 
box.

2 Specify the Database from which you want to load the queries.

3 Do one of the following to select the desired queries from the selected 
database:

• To load all queries, enter the “%” character in the Query Tag field.
• To load a range of queries, enter the range in the Query ID field (for 

example, “1-100”).
• To load a specific query, enter the query tag in the Query Tag field, or the 

query id in the Query ID field.

4 Click Browse QCD to load the specified queries into the list of Available 
Execution Plans.

5 To load plans from additional servers, click Connect To.

6 To load offline plans, click Offline Plan.

7 To select plans for opening, in the Available Execution Plans list, click on the 
Select column of the desired plan(s). A check will mark the plan as selected.

8 Once the desired plans are selected, click Add to add the selected plan(s), to 
the Selected Execution Plans list. To add all available plans, click Add All.

9 Once the desired plan(s) are in the Selected list, click Open to display the 
plan(s).
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Step 2:  Creating the Visual Comparison

Follow this procedure to create a visual comparison of execution plans:

Step 3:  Comparing Steps in Execution Plans

Follow this procedure to create a visual comparison of execution plans:

Step Action

1 Once you have loaded the desired execution plans, select Plans > Compare 
from the menu bar.

2 Select one query to be used for the basis of the comparison by double-clicking 
on its row. The query row turns green to indicate it is selected.

3 Select the plans to be compared to the base plan by clicking on its Compare 
column. A check mark in this column indicates the query is selected for 
comparison.

4 Click OK to create the comparison.

5 Note that the differences are displayed by a red arrow next to the appropriate 
steps. Move the mouse pointer over this red arrow for Tool Tip text explaining 
the differences.

Step Action

1 Once you have loaded the desired execution plans, select Select Plans > 
Compare Steps from the menu bar.

2 In the dialog that appears, double-click on the step you want to use as base for 
the comparison.

3 Single-click on the steps you want to compare to the selected base step.

4 Click Compare to create the comparison.
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Displaying Differences in Explain Text

Follow this procedure to create a report showing the differences in explain text 
between two queries.

Step Action

1 Select Plans > Explain Text Diff from the menu bar. This displays the Select 
Execution Plans for Explain Text Differences dialog box.

2 Select the Database from which you want to load the queries.

3 Do one of the following to select the desired queries from the selected 
database:

• To load all queries, enter the “%” character in the Query Tag field.
• To load a range of queries, enter the range in the Query ID field (for 

example,  1-100”).
• To load a specific query, enter the query tag in the Query Tag field, or the 

query id in the Query ID field.

4 Click Browse QCD to load the specified queries into the list of Available 
Execution Plans.

5 To load opened plans for the compare operation, check the Opened Plans box, 
then click Browse to load the plans into the list of Available Execution Plans.

6 To load plans from additional servers, click Connect To.

7 To load offline plans, click Offline Plan.

8 To select plans for comparison, in the Available Execution Plans list, click on the 
Select column of the desired plan(s). A check will mark the plan as selected.

9 Once the desired plans are selected, click Add to add the selected plan(s), to 
the Selected Execution Plans list. To add all available plans, click Add All.

10 Select a base plan for the comparison by double-clicking on a row in the 
Selected Execution Plan list.

11 Select a plan to compare to the base by clicking in its Compare column. A check 
will mark the plan for comparison. 

Note: Only two plans can be compared at a time.

12 Click Compare to display the report. The textual differences are displayed in 
red.
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13 Use the commands on the Navigate menu (or the corresponding buttons on 
the tool bar) to move from one difference to another.

14 You can also do the following:

• To view the Execution Plan, select View > Execution Plan from the menu 
bar.

• To view Statement text, select View > Explain Text from the menu bar.

Step Action
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The Teradata Manager Applications

This chapter provides a brief description of each Teradata Manager application. 
The applications are listed in the order that they appear on the Executive pull-
down Menus.
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Program Icon - Executive
Program Icon - Executive

Function

The Executive provides the interface for working with all of the other Teradata 
Manager applications. It allows you to:

• Tailor your Teradata Manager working environment
• Work with profiles and profile logs
• Launch other Teradata Manager Applications
• Enable and disable autostart applications

How It Works

It starts automatically each time you start Teradata Manager, and it runs 
continuously until you exit the application.

Getting Started

Make sure you have created a default profile using Profile Builder before 
launching the Executive.  See “Create a Default Profile for Teradata Manager” 
on page 2-7 for more information.
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Program Icon - Profile Builder
Program Icon - Profile Builder

Function

Profile Builder allows you to define and modify profiles. A profile is a set of 
Teradata Manager applications that is configured for a specific type of 
monitoring activity. This ability to create custom configurations provides an 
effective way for you to use Teradata Manager in various operational 
situations. For example:

• If you need to access more than one Teradata RDBMS, you can define 
different profiles for each database.

• If you need more than one person or group of people to use Teradata 
Manager, you can define different profiles for each person or group.

• If your operational needs change on a regular basis, or from one shift to 
another, you can define different profiles for each shift.

How It Works

Profile Builder runs in a standard Windows application window. It runs 
separately from the Executive, and you can use Profile Builder whether the 
Executive is running or not.

Getting Started

The first thing you need to do is to create a default profile. This profile will 
allow you to start Teradata Manager Executive and access the desired 
applications. 
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Tools Menu - Alert Control Module

Function

The Alert Control Module (ACM) initiates the alerting process for Teradata 
Manager.

How It Works

ACM reads the Alert system tables for the Teradata RDBMS associated with the 
current Teradata Manager profile, and starts the set of Data Collectors that are 
required to support the current Alert Policy.

It then monitors the Alert Policy for changes. If the user changes the Alert 
Policy so that a new collector must be started up, or a running collector is no 
longer required, ACM takes the appropriate action. ACM can also accept 
requests from other Teradata utilities or user programs to generate alerts.

The Alert Control Module writes a detailed report of all Alert activity to the 
ACM Log File.
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Tools Menu - Alert Policy Editor

Function

The Alert Policy Editor allows the DBA to define the actions that should take 
place when Performance or Database Space events occur on one or more 
Teradata machines. These events are defined based on data collected from the 
following areas:

• PM Physical Resource data
• PM Virtual Resource data
• Database Space information
• Session information
• Teradata messages
• Event Combinations

The collection rates for each type of data can be set independently by data type 
and machine.
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Tools Menu - Alert Viewer

Function

The Alert Viewer provides the user a with single view point on the overall 
system performance for one, or multiple, Teradata RDBMS systems. Through 
the easy to use graphical user interface and colored icons, users can easily drill 
down from an overall picture to identify the problem area, possibly preventing 
a hazardous situation.

The Alert Viewer also provides a graphing function, which allows you to 
display a graph for any data point value by simply clicking on it.

How It Works

Each profile is displayed as a top-level item in a tree structure, with the related 
system level data displayed in the panel to the right. Below each profile are the 
group items for Nodes, Vprocs, Sessions, RDBMS Events, Monitor Alerts, and 
Alert Requests. These second level items display a List View of third level items 
consisting of Nodes, Vprocs or Sessions. For example, the Nodes group item 
will display the number of Node records below it. The third level shows the 
actual Node, Vproc or Session together with the associated detail data.

Important

Before running the Alert Viewer, you must first start the Alert Control Module 
(ACM). ACM will in turn start the necessary Data Collectors which allow the 
Alert Viewer to get data from the ServerPC.
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Tools Menu - BTEQWIN

Function

BTEQWIN is an application that allows the user to run multiple DMTEQ 
sessions and to access different databases simultaneously under Teradata 
Manager.

How It Works

BTEQWIN provides pulldown menus and dialog boxes that you use to send 
SQL statements to the Teradata RDBMS. By default, BTEQWIN is configured as 
a menustart application under the Tools pulldown menu on the Executive 
menu bar of the DEFAULT profile.

What It Does

Running BTEQWIN allows you to:

• Run multiple DMTEQ sessions simultaneously under the Teradata 
Manager

• Access different RDBMS’s simultaneously under the Teradata Manager
• Scroll back the window display
• Save all BTEQWIN output to a file 
• Use editing functions to modify a BTEQ or a SQL statement 
• Re-send a BTEQ or a SQL statement to the Teradata RDBMS without 

retyping
• Run a BTEQ script using drag and drop functionality
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Tools Menu - DMTEQ

Function

DMTEQ is a version of the Basic Teradata Query (BTEQ) Facility that runs 
under Teradata Manager. Use DMTEQ to submit Teradata SQL statements and 
requests to the associated Teradata RDBMS with the use of macros.  

How It Works

DMTEQ runs in a standard Windows application window.  By default, DMTEQ 
is configured as a menustart application under the Tools pulldown menu on 
the Executive menu bar of the DEFAULT profile.
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Tools Menu - RDBMS Setup

Function

RDBMS Setup is a tool for setting up the Teradata RDBMS with the databases, 
tables, macros and users necessary to run Teradata Manager.

How It Works

RDBMS Setup uses your parameters to generate SQL statements for creating 
and modifying databases/tables/macros/users on the specified RDBMS. Each 
SQL statement and whether it was submitted successfully or unsuccessfully is 
logged in the main window of the application.
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Tools Menu - Time Synchronizer

Function

Time Synchronizer allows you to synchronize your PC clock with the Teradata 
RDBMS. 

You can run Time Synchronizer in interactive mode to:

• Synchronize the clock on your PC with the clock on the associated Teradata 
RDBMS.

• Set the clock on your PC.

You can run Time Synchronizer in batch mode to:

• Periodically compare both times.
• Notify you if the two times differ by more than a specified amount.
• Re-synchronize the clocks when they are out of synchronization.

Note:  The logged on user must have permission to alter the PC time.
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Tools Menu - Visual Explain

Function

Visual Explain provides a visual depiction of the execution plan chosen by the 
Teradata RDBMS Optimizer to access data. It does this by turning the output 
text of the EXPLAIN modifier into a series of easily readable icons. 

Visual Explain is especially useful in comparing the execution plans of similar 
queries. Using the compare feature allows you to easily resolve Optimizer 
related discrepancies.

How It Works

Visual Explain reads the contents of the Query Capture Database (QCD) and 
turns it into a series of icons. In order to view an execution plan using Visual 
Explain, the execution plan information must first be captured into the QCD 
using the Query Capture Facility (QCF), which includes the “insert explain” 
and “dump explain” commands.
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Tools Menu - WinDDI

Function

WinDDI (Windows Data Dictionary Interface), is the Teradata Manager 
application that you use to perform database administration tasks on the 
associated Teradata RDBMS computer.

How It Works

WinDDI runs in a standard Windows application window.

By default, WinDDI is configured as a menustart application on the Tools 
pulldown menu of the Executive menu bar in the DEFAULT profile. WinDDI is 
also configured as a separate application icon in the Teradata Manager folder so 
you can run it separately, independent of the Executive

What It Does

WinDDI provides an easy-to-use Windows-based graphical interface to the 
Teradata RDBMS Data Dictionary. You may use WinDDI to perform the 
following functions:

• Create, Modify and Drop Users or Databases
• Create Tables (using ANSI or Teradata syntax)
• Grant or Revoke access/monitor rights
• Copy Table, View or Macro definitions to another database, or to another 

system
• Drop or Rename Tables, Views or Macros
• Move space from one database to another
• Run an SQL query
• Display information about a Database
• Display information about a Table, View or Macro

WinDDI keeps a record of all the actions you take and can optionally save this 
record to a file. This record contains a time stamp together with the SQL that 
was executed, and other information such as the statement’s success or failure.  

Prerequisites

To use the viewing functions of WinDDI, you must have Select access to the 
DBC views of the Teradata RDBMS. To use the Copy, Drop, Create or Grant 
tools you must have the corresponding privilege on the table or database that 
you are trying to modify or create. To use the Browse or Row Count features 
you must have select access to the Table or View.

WinDDI has no dependencies on any other Teradata Manager application.
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Performance Menu - Dynamic Utilization 
Charting (Using PM & PC)

Function

Dynamic Utilization Charting (using PM & PC), or DUC (using PM & PC), 
displays near real-time Teradata RDBMS resource usage data in chart format on 
your Teradata Manager PC. You can set the frequency at which the charts are 
updated. The update frequency range is 6 to 3600 seconds while the system is 
running. 

The charts can help you:

• Detect down nodes and down Vprocs.
• Detect resource usage abnormalities on the associated Teradata RDBMS, 

such as the CPU Parallelism among Vprocs and Nodes.
• Detect resource usage abnormalities on the associated Teradata RDBMS.

How It Works

DUC (using PM & PC) runs in a standard Windows application window. By 
default, DUC (using PM & PC) is configured as a menustart application under 
the Performance pulldown menu on the Executive menu bar of the DEFAULT 
profile.
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Performance Menu - Performance Data 
Analyzer

Function

Performance Data Analyzer (PDA) summarizes Teradata RDBMS resource 
usage data in chart format on your Teradata Manager PC. You can chart a 
single column for several time periods, or several columns for a single time 
period. Resource usage data comes from the resource usage tables on the 
associated Teradata RDBMS by Resusage Data Collector.

How It Works

Performance Data Analyzer runs in a standard application window. By default, 
it is configured as a menustart application under the Performance pulldown 
menu on the Executive menu bar of the DEFAULT profile.

Because Performance Data Analyzer relies on resusage data files, you must first 
run Resusage Data Collector to generate data before you can start PDA.
Teradata Manager Getting Started GuideA – 14



Appendix A: The Teradata Manager Applications
Performance Menu - PM Data Collector
Performance Menu - PM Data Collector

Function

The PM Data Collector is the component of Teradata Manager’s client/server 
support facility that gets performance monitoring (PM & PC) data from the 
Teradata RDBMS. 

PM Data Collector serves as a single point of Teradata RDBMS performance 
data collection. This means you can run applications that report RDBMS 
activity and performance data while minimizing the impact of obtaining such 
data from the RDBMS.

How It Works

The PM Data Collector and TMServer typically run on a central administrative 
server. Data is distributed to requesting applications (such as Teradata 
Performance Monitor, Session Information, and Alert Viewer) by the TMServer 
application. Applications request performance data via the TMClient 
application. All other Teradata Manager workstations run on desktops as 
clients and receive performance data from the central server.

Prerequisites

To use all of the functions in PM Data Collector, you must have the following 
user privileges on the Teradata RDBMS:

• SETSESSRATE
• SETRESRATE
• MONSESSION
• MONRESOURCE

Resusage Tables

Before PM Data Collector will be able to return any data you will need to use 
the xctl utility to enable the following Resusage tables on the Teradata RDBMS 
system(s) that you wish to monitor:

• SVPR
• SPMA
• SCTL
• IPMA
• SLDV
• SHST
Teradata Manager Getting Started Guide A – 15



Appendix A: The Teradata Manager Applications
Performance Menu - PM Data Collector
After enabling these tables you must use Teradata Performance Monitor, or the 
Operator commands, to set the session and resource collection rates to non zero 
values.

Starting the Collector

There are two methods of starting the collector: if the Alerts system is in use, 
then the collector is automatically started by the Alert Control Module; 
otherwise the collector can be started manually by selecting the appropriate 
menu command in the Teradata Manager Executive (by default Performance > 
PM Data Collector).

In both cases the collector automatically starts a partner TMServer.

Note:  The DEFAULT profile may be customized by administrator so that the 
collector does not appear on any of the menus. This way the day-to-day user is 
not tempted to run an unnecessary copy of the PM Data Collector.
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Performance Menu - Teradata Performance 
Monitor

Function

Teradata Performance Monitor is the Teradata Manager application that you 
use to monitor the general health of a Teradata RDBMS. It also allows you to 
analyze current performance and both current and historical session 
information, and to abort sessions that are causing system problems.

Where It Runs

Teradata Performance Monitor runs in a standard Windows application 
window.  By default, Teradata Performance Monitor is configured as a 
menustart application under the Performance pulldown menu on the Executive 
menu bar of the DEFAULT profile.

How It Works

Teradata Performance Monitor uses the Teradata RDBMS Performance Monitor 
to collect near real-time system configuration, Resource usage, and Session 
information from the Teradata RDBMS. It then formats and displays this 
information as requested.

Teradata Performance Monitor displays this performance data on four sets of 
screens. One for each of the following types of data:

• General Health information (Configuration and Summary)
This data is displayed on the main screen and is refreshed automatically at 
a user defined interval. This data can also be displayed as a chart of 
summary values over time by clicking on the Chart button.

• Resource information (Nodes and Vprocs)
This data is collected and displayed only when requested by the user. 
Graphs showing a user selected data point for each Node (or Vproc) may be 
displayed by double clicking the required data point. 

• Session Information (Statistics and Lock information)
This data is collected and displayed only when requested by the user. The 
session summary screen shows all the sessions currently logged onto the 
system and allows the user to filter these sessions and to sort them in 
various ways. It also shows which sessions are currently blocked.
Detail session information, for a specific session may be seen by double 
clicking on that session. Graphs showing a user selected data point for each 
Session may be displayed by double clicking the required data point. 
Graphs showing data point A by data point B may be displayed by clicking 
on one data point and dragging it to the other.
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Detail lock information may be displayed by double clicking on any session 
that is shown to be blocking, or blocked by, another session.
You can also display Session Sqew information and SQL Text/Explain 
steps.

• Historical session information 
A list of  historical session files is displayed.  By choosing from this list the 
user may analyze a problem after the fact. The data itself is displayed on the 
regular Session Information screens.

General Notes

The Main Teradata Performance Monitor screen must remain open. Closing it 
will end your Teradata Performance Monitor session.

In general, each screen is displayed maximized within the parent frame. This 
may be required in order to see the entire screen contents.

If an error occurs in this program please see Problem Resolution for more 
information.

Prerequisites

To use all of the functions in Teradata Performance Monitor, you must have the 
following user privileges on the Teradata RDBMS:

• SETSESSRATE
• SETRESRATE
• MONSESSION
• MONRESOURCE
• ABORTSESSION

Resusage Tables

Before Teradata Performance Monitor will be able to return any data you will 
need to use the xctl utility to enable the following Resusage tables on the 
Teradata RDBMS system(s) that you wish to monitor:

• SVPR
• SPMA
• SCTL
• IPMA
• SLDV
• SHST

After enabling these tables you must use Teradata Performance Monitor, or the 
Operator commands, to set the session and resource collection rates to non zero 
values.
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Status Bar

The Status Bar across the bottom of the window provides three important 
pieces of information. It tells you:  

• whether you are logged on or not, 
• what Teradata Database you are logged on to, and 
• what is Teradata Performance Monitor's processing state, which is either 

Idle or processing a request.
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Performance Menu - Resusage Data 
Collector

Function

Resusage Data Collector (RDC) gathers information for AMP vprocs, PE vprocs 
and Nodes. RDC runs as a minimized icon and requires very little user 
interaction.

What It Does

Use Resusage Data Collector to perform the following functions:

• Collect data from tables on the associated Teradata RDBMS.  (The Resusage 
tables on the RDBMS must be enabled and logging must also be enabled.)

• Write the data to files and memory objects on your Teradata Manager PC.
• Access the resource usage tables.
• When configured, access data from other tables to depict trends over user 

defined intervals using PDA.

How It Works

Resusage Data Collector (RDC) requires, or uses, the following:

• A current configuration file, DBCONFIG.DAT, must be present in the 
PARAMS sub-directory of the profile.  If the configuration is not there, RDC 
will create one.

• RDC uses a 10 minute logging cycle. 
• RDC requires that your PC and the RDBMS be in synchronization.  (Run the 

Time Synchronizer application to insure that your PC is not more than one 
minute ahead of the system.)

Use RDC to collect only the data for the current logging cycle on the associated 
Teradata RDBMS.  A file for each of the three data types is generated with the 
collected data is found in \<install_directory>\profiles\<profile_name>\resbase.  
Teradata Manager Getting Started GuideA – 20



Appendix A: The Teradata Manager Applications
Production Control Menu - Configuration Check
Production Control Menu - Configuration 
Check

Function

Configuration Check is a Teradata Manager utility that collects configuration 
information related to an associated Teradata RDBMS and stores it on the client 
PC. 

Where It Runs

Configuration Check runs in a minimized window, and can be run as an 
autostart application. Locking Logger and Resusage Data Collector run it 
automatically to create the dbconfig.dat file.

It is recommended that you run Configuration Check whenever the number of 
Nodes/AMPs/PE Vprocs changes on the database server.
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Production Control Menu - Error Log 
Analyzer

Function

Error Log Analyzer (ELA) allows you to view the error log system tables on the 
Teradata RDBMS. You may view the log tables

• by Category
• by Message Screen, and
• by Reports.

Teradata RDBMS monitors hardware and software error events and logs error 
messages into two separate tables: 

• dbc.software_event_log 
• dbc.hardware_event_log

The ELA macros included with the Teradata Manager include AllRestarts, 
BynetEvents, DiskEvents, EventCount, LogHistory, MemEvents, 
MiniCylPacks, PackDisk and RestartLogonEvents. You can add other macros 
by using application-specific entries.

Where It Runs

Error Log Analyzer runs in a standard application window. By default, it is 
configured as a menustart application under the Production Control pulldown 
menu on the Executive menu bar of the DEFAULT profile.

Application

Error Log Analyzer (ELA) is used to create a daily report of Teradata RDBMS 
errors which occurred during the previous 24-hour period. Using the report, 
you can determine if anything unusual occurred on the Teradata RDBMS 
during that period and correct any problems, if needed.

Macros

You can set up Error Log Analyzer as an autostart application from Profile 
Builder or from the Executive. Additional macros can be added using 
application-specific entries from Profile Builder. The ELA macros run under 
DMTEQ.
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Production Control Menu - Locking Logger

Function

The Teradata Manager Locking Logger application is a menu-driven interface 
to the Locking Logger console utility of the Teradata Database Software 
(RDBMS). 

When the Locking Logger option is enabled, the Teradata RDBMS maintains 
ongoing logs of:

• Transaction Identifiers
• Session Identifiers 
• Lock Object Identifier
• Lock Levels associated with executing SQL statements which have been 

delayed because of database lock contention.

Where It Runs

Locking Logger runs in a standard application window. By default, it is 
configured as a menustart application under the Production Control pulldown 
menu on the Executive menu bar of the DEFAULT profile.

Application

The Locking Logger application runs the Locking Logger console utility which 
creates a table of information extracted from the transaction logs. The Locking 
Logger application can then use this table to create a report that helps you 
determine whether system performance has been degraded by an 
inappropriate mix of SQL statements.

Enabling Locking Logger

You must enable the Locking Logger option before you can use the Teradata 
Manager Locking Logger application. Modify the RDBMS Control Record by 
running the dbscontrol console utility via Remote Console. You should then 
restart the system.
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Production Control Menu - LogOnOff 
Usage

Function

LogOnOff Usage presents daily, weekly, and monthly logon statistics based on 
information in the DBC LOGONOFF view on the associated Teradata RDBMS. 
Three macros are included with LogOnOff Usage to help you retrieve this 
information:

Where It Runs

LogOnOff Usage runs in a standard application window.  By default, it is 
configured as a menustart application under the  Production Control pulldown 
menu on the Executive menu bar of the DEFAULT profile.

Application

LogOnOff Usage allows you to create and execute macros on the associated 
Teradata RDBMS and to display the results in a scrollable window. 

The DEFAULT profile has been configured to contain three macros which 
present you with daily, weekly, and monthly logon statistics:  DailyReport, 
WeeklyReport and MonthlyReport.

Additional Macros

You can create additional macros or modify existing macros via the Application 
Specific Entries feature of the Profile Builder. The SQL scripts for the included 
macros serve as templates for any new macro you create.

This report... Displays...

DailyReport the number of logons across several days, either in ten-
minute or one-hour intervals, grouped by time interval and 
user.

WeeklyReport a summary of all logons for the last ten weeks, grouped by 
week.

MonthlyReport a summary of all logons over the last month (from 30 days 
previous to the current date) grouped by date.
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Production Control Menu - Remote 
Console

Function

Remote Console allows you to run many of the Teradata RDBMS console 
utilities from your Teradata Manager PC. Supported utilities include:

This utility... Allows you to...

Abort Host cancel all outstanding transactions running on a host that is 
no longer operating.

CheckTable check for inconsistencies in internal data structures and for 
corruption.

Configure review and update the configuration of the Teradata 
RDBMS.

DBS Control display the values of the DBS Control Record fields. You can 
also modify the values, if the field is writable.

Ferret display and set various disk space utilization attributes, and 
dynamically reconfigure the data on the disks to correspond 
with the selections.

Gateway Global inspect and modify the gateway operating parameters for 
any network attached to the associated Teradata RDBMS.

Lock Display see a snapshot capture of all real-time database locks. 

Note:   You can only invoke this utility against a V2R4 or 
higher RDBMS.

Operator Console run supervisor commands to manage the programs that 
perform Teradata RDBMS operations.

Priority Scheduler control resource allocation for RDBMS sessions based on 
either session-related priority designations or system-level 
scheduling parameters.

Note:   You can only invoke this utility against a V2R4.1 or 
higher RDBMS.

Query Configuration display the current Teradata RDBMS configuration.

Query Session monitor the state of database sessions on logical host IDs 
attached to the Teradata RDBMS.

Recovery Manager monitor the progress of a Teradata RDBMS recovery. 
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Where It Runs

Remote Console runs in a standard application window.  By default, it is 
configured as a menustart application under the Production Control pulldown 
menu on the Executive menu bar of the DEFAULT profile.

Application

The Remote Console log contains the input and output for all console utilities 
started. The list of available console utilities is taken from the application-
specific entry RCONSUTILS.  When you select a utility to run, the output for 
the utility appears on the main window. 

The script feature of Remote Console allows you to record commands 
associated with starting, running, and stopping console utilities. The 
commands you enter are saved as scripts and can be played back at a later time. 
Scripts may be run interactively from the main menu via the Scripts > Run 
command, or in batch mode by setting up an Autostart entry in the Executive.

Show Locks provide information about hosts utility locks.

Vproc Manager obtain the status of Vprocs, change Vproc states, initialize 
and boot a specific Vproc, initialize the Vdisk associated with 
a specific Vproc, or force an RDBMS restart.

This utility... Allows you to...
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Production Control Menu - Resource 
History

What It Does

Resource History provides reports that show the maximum and average usage 
for Logical Disk Vprocs (LDVs), AMP Vprocs, and PE Vprocs on the associated 
system. The NODE command is used to run NODE usage macros on the 
associated Teradata RDBMS. 

Where It Runs

Resource History runs in a standard Windows application window. By default, 
Resource History is configured as a menustart application under the 
Production Control pulldown menu on the Executive menu bar of the 
DEFAULT profile.

Applications

Resource History provides pulldown menus and dialogs that you use to 
provide reports that show the maximum and average use of Teradata RDBMS 
system components. 

Macros

Resource History includes the following macros to assist you retrieve this 
information.

This command... Creates a report showing...

AverageUse the average Logical Disk, AMP, or PE Vproc usage for up to 
31 days, starting on the date you specify.

MaximumUse the maximum Logical Disk, AMP, or PE Vproc usage for up 
to 31 days, starting on the date you specify.

DifferenceUse the difference in Logical Disk, AMP, or PE Vproc usage 
(MaximumUse - AverageUse) for each hour for up to 31 
days, starting on the date you specify.

LDVActivity logical Disk activity at the controller level for 31 days, 
starting on the date you specify. 

NODE CPU Average 
Util

NODE CPU average utilization for each hour for up to 31 
days, starting on the date you specify.

NODE CPU Efficiency NODE CPU Efficiency (Average/Maximum) for each hour 
for up to 31 days, starting on the date you specify.
Teradata Manager Getting Started Guide A – 27



Appendix A: The Teradata Manager Applications
Production Control Menu - Resource History
NODE LDV Activity the Logical Disk activity per NODE for 31 days, starting on 
the date you specify.

ResNodeByGroup general system information summarized by Node Groups.

ResMemByGroup The ResMemByGroup report provides information about 
memory allocation, aging, paging, and swapping activities 
on the Nodes, summarized by Node Groups. The resulting 
numbers become the average across the group. 

ResNetByGroup The ResNetByGroup report provides information about 
network traffic on the Nodes, summarized by Node 
Groups. The resulting numbers become the average across 
the group.

ResCpuByGroup The ResCpuByGroup report provides information about 
how the Nodes are utilitzing the system CPUs, summarized 
by Node Groups. The resulting numbers become the 
average across the group. 

ResAmpCpuByGroup The ResAmpCpuByGroup report provides information 
about how the AMPs are utilitzing the system CPUs, 
summarized by Node Groups. The resulting numbers 
become the average across the group. 

ResPeCpuByGroup The ResPeCpuByGroup report provides information about 
how PEs are utilitzing the system CPUs, summarized by 
Node Groups. The resulting numbers become the average 
across the group.

ResHostByGroup The ResHostByGroup report provides general 
communication link information summarizing statistics by 
node grouping. The HstType is also used in the GroupBy 
statement so that IBM Host channels and Network links can 
be differentiated in the output rows. Most of the resulting 
numbers become the average across the group.

ResLdvByGroup The ResLdvByGroup report provides general logical disk 
information, summarizing statistics by node grouping. 
Most of the resulting numbers become the average across 
the group. The exception is the Max number of concurrent 
requests, which reports the maximum value for any logical 
disk in the group.

This command... Creates a report showing...
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Production Control Menu - Session 
Information

Function

Session Information (SI) uses the Teradata RDBMS Performance Monitor to 
collect the session PM data from the Teradata RDBMS. It then formats and 
displays key information about each session, based on the current collection 
rate. SI shows logon sessions in different categories, and helps you to identify 
blocked and long idle sessions and abort sessions as desired on the Teradata 
RDBMS.

Where It Runs

SI runs in a standard Windows application window. By default, SI is configured 
as a menustart application under the Production Control pulldown menu on 
the Executive menu bar of the DEFAULT profile.

Reports

Most of the SI reports are categorized based on the session’s status.  These 
reports can be used in many different ways. You can open the reports based on 
your needs, and set up the desired Collection Frequency. Once this is done SI 
will update the reports automatically. 

The following reports provide very useful information, and you may wish to 
leave them open all the time:

This report... Shows you...

Summary Report how many sessions are logged on to the system, their status 
and where they are logging on from.

Blocked Report blocked sessions on the system.  Double clicking on the 
blocked session in the report displays the Host/Session 
detail dialog.  This dialog shows who is blocking the 
session, and allows you to examine how many sessions are 
being blocked. You can also use the Host/Session dialog to 
abort  the session.

Idle Report idle sessions on the system. You can define thresholds for 
the Idle report so that all long idle sessions will be displayed 
in this report.  You can also define the Auto Abort Threshold 
so that the long idle sessions will abort automatically.  It is 
recommended that local filter be defined with this report in 
order to avoid aborting critical sessions/users. 
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Production Control Menu - Session Information
Connection Options

SI can either:

• Logon to the RDBMS to get the PM & PC session data from the system 
directly.

• Connect to another Teradata Manager PC that is running Data Collector 
and TMServer, and get the PM & PC data from the server PC.

What it means

When SI is connected to a server PC, it starts a partner TMClient application in 
order to set up the link between itself and the Teradata Manager Server PC. 

Changing connections

The type of connection can be changed at any time. You can have SI disconnect 
from the Server and logon directly to the RDBMS. As long as you have the 
proper privileges,  you can abort sessions or change the Local Session Rate.
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Production Control Menu - Space Usage
Production Control Menu - Space Usage

Function

Space Usage is the Teradata Manager application that you use to monitor the 
use of disk space on the associated Teradata RDBMS computer and to reallocate 
permanent disk space from one database to another.

How It Works

Space Usage runs in a standard application window.  By default, Space Usage is 
configured as a menustart application under the Production Control pulldown 
menu on the Executive menu bar of the DEFAULT profile.

What It Does

Space Usage has some functionality overlap with WinDDI. Both Space Usage 
and WinDDI provide capabilities to move permanent space between databases 
and to view the database hierarchy and space utilization reports. Space Usage 
offers a richer set of reports specifically for monitoring disk space usage on the 
Teradata RDBMS. Space Usage also contains direct support for changing the 
database hierarchy (via Move Database command).

Note:  Access to the Teradata RDBMS Show Space utility is through the Ferret 
file system tool.  To use all of the Space Usage functions, you must have 
sufficient privilege to run Ferret on the associated Teradata RDBMS computer.  
You must also have the following privileges on the associated databases:

• CREATE DATABASE
• DROP DATABASE

Application

Space Usage's reports and commands are useful for:

• Monitoring permanent space on your Teradata RDBMS for signs of 
performance bottlenecks (high utilization), or under utilization (Cylinders 
by Processor, Space by Processor, Space by Database and Table Space 
reports).

• Giving additional database capacity to individual users or databases (Move 
Space command).

• Managing the database hierarchy (Hierarchy report and Move Database 
command).
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Production Control Menu - Statistics Collection
Production Control Menu - Statistics 
Collection

Function

Collecting statistics on a column or Key field assists the query optimizer in 
choosing an execution plan that will minimize query time. Because the 
optimizer bases the execution plan on the actual values in the table, statistics 
should be updated whenever there have been a significant number of row 
additions or deletions.

What It Does

Statistics Collection allows you to:

• Determine which tables have statistics
• Create statistics for columns or indexes
• Drop statistics by column/index, or for the entire table
• Update statistics for column/index, table, database, or the entire Teradata 

RDBMS

This application can also help you create SQL scripts to collect/drop statistics 
and setup the Autostart menu.

How It Works

Statistics Collection displays Teradata RDBMS statistics in three windows:

• The Database window, which provides you with a tree view of the 
databases.

• The Table window, which displays the tables in the selected database.
• The Statistics window, which displays the columns/indices for the selected 

table.
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Production Control Menu - System Maintenance
Production Control Menu - System 
Maintenance

Function

System Maintenance is an essential member of Teradata Manager, enabling 
your team of DBAs and power analysts to monitor and to keep your Teradata 
database systems running smoothly from desktops throughout the 
organization.

How It Works

System Maintenance provides pulldown menus and dialogs that you use to run 
applications to maintain and monitor system tables. The commands used to 
delete rows in system tables and to reset accounting statistics for AMP usage 
and disk space are invoked from the Clean menu. Other system monitoring and 
reporting commands are found in the Configuration menu.

What It Does

System Maintenance includes macros that perform the following functions in 
order to help you perform maintenance tasks:

• Rows can be deleted from DBC.SW_EVENT_LOG, 
DBC.HW_EVENT_LOG, DBC.LOGONOFF, DBC.SECURITYLOG, and 
DBC.RESUSAGE tables based on the beginning and ending dates that you 
specify.  

• For cleaning AMP usage data, a choice is provided to ’clean’ (set columns to 
zero), or ’delete’ (delete the matching rows) in DBC.AMPUSAGE view.

• DiskIO and CPUTime can be reset in DBC.AMPUSAGE view.  
• PeakPerm and PeakSpool can be reset in DBC.DISKSPACE view.   
• ReconfigCheck estimates the number of bytes required for an AMP re-

configuration.  
• StorageMap shows spool space, perm space, used perm and other useful 

statistics for each database and user.  
• NewModObjects shows new and modified tables, views, and macros for 

each database.  
• DroppedObjects shows dropped tables, views, and macros for each 

database.
• Selections under the Audit menu allow you to produce reports from the 

AccessLog.
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Utility Program - SQL Data Collector
Utility Program - SQL Data Collector

Function

The SQL Data Collector is a component of Teradata Manager’s Alerts system 
that runs automatically on the central administrative system. (The central 
administrative system is the computer on which server-side Teradata Manager 
components are run: Data Collector, TMServer, ACM.) 

The Alert Control Module starts and stops the SQL Data Collector. It also tells 
the collector what databases to monitor and how often. This application 
normally does not require user interaction.

What It Does

The SQL Data Collector periodically queries the RDBMS for perm space 
utilization data and compares the results against database space thresholds 
defined in the Alert Policy. It also queries the Teradata software event log for 
messages that have been specified as alertable RDBMS Events in the alert 
policy. When a threshold is exceeded, the collector executes the corresponding 
alert actions (also defined by the Alert Policy).

The SQL Data Collector also monitors the Teradata software event log for 
alertable event messages based on the RDBMS Events category of the active 
alert policy.

Where It Runs

This application is started automatically by the Alert Control Module. 
Normally, the program will run in minimized mode.
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Utility Program - Log Change
Utility Program - Log Change

Function

Log Change is a utility used to change the Executive Log File at specific 
intervals. Entries for all the Teradata Manager activities are in the Executive 
Log File displayed in the work space of the Executive window.  The Executive 
maintains a separate log file for each profile in a corresponding LOGS directory.  

For example, the log file for the DEFAULT profile is located in the 
\NCR\Teradata Manager\profiles\default\logs directory.

Log Change does not include a user interface, and does not have application-
specific entries. All dependencies for Log Change are managed by Teradata 
Manager.
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Utility Program - Log Delete
Utility Program - Log Delete

Function

Log Delete is a Teradata Manager utility that allows you to delete the Executive 
log file or Remote Console log file on a random basis, or automatically at 
specific intervals. It can be run as an autostart application.

The Executive and Remote Console maintain separate log files in the LOGS 
subdirectory of each profile directory. The profile directories are stored under 
the user’s Personal or My Documents folder.

Log file names are as follows:

• Executive log files begin with the letter d.
• Remote Console log file names begin with the letter r.

The Executive and Remote Console log files are closed and new log files are 
opened when the current log files are full. A log file is considered full when it 
contains approximately 30,000 lines. 
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Utility Program - TM Server
Utility Program - TM Server

What It Is

TMServer is a component of the Teradata Manager client/server support 
facility. It allows you to configure a Teradata Manager workstation as server to 
distribute performance monitoring (PM & PC) data to the remote workstations 
that run TMClients. 

What It Does

TMServer is an essential member of Teradata Manager's Client/Server support 
facility, enabling your team of DBAs and power analysts to monitor your 
Teradata database systems from desktops throughout the organization while 
minimizing the impact of such monitoring on critical database production jobs.

Data is collected by the Data Collector application. Applications request 
performance data via the TMClient application.  

How It Works

In a typical setup, the Data Collector and TMServer run on a central 
administrative server. All other Teradata Manager workstations run on 
desktops as clients, getting performance data from the central server.

TMServer is automatically started when Data Collector is initialized on the 
workstation that is to act as the server.

TMClient is started by a PM & PC application. 

Default Port Number

TMServer uses a default port number starting from 2010. You can override that 
port number by using the parameter “-t” to start TMServer. To do that, you 
have to close the copy of TMServer that has been started from Data Collector. 
Then go to the Run command under Profile menu on the Executive and type 
the following in the Run command dialog:

TMServer -tXXXX

where XXXX is the port number that you want to use.

User Interaction

TMServer does not require user interaction and is therefore defaulted to run in 
minimized mode. You only need to open the application to change the 
maximum number of clients allowed to connect, or to view the server activities. 
Do not close TMServer while there are clients connected.
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Utility Program - TM Server
Relation to Teradata Applications

The Data Collector and TMServer work together to make Teradata RDBMS 
performance data available to PM & PC applications. TMServer is 
automatically started by the Data Collector. You should not start it manually, 
except for special circumstances (such as to use a specific port number, as 
described above).
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